How do you remove an alien partition

While checking my partitions I saw the following partition.
/dev/sda Fujitsu MHW2120B 111.79GB.
When I add up all the space on my partitions it is 111GB too much.
I have a HP Pavilion laptop & I have never had any Fujitsu hardware in it.
When I tried to remove it, it removed all my other partitions but wouldn’t remove this one.
I then tried re install linux & re partition my hard drive but still it wouldn’t remove it.
Does anyone have any suggestions?

On 06/15/2013 05:16 PM, Hermes14 wrote:
> Does anyone have any suggestions?

to make a meaningful suggestion we need a little more info, so please
show us the terminal output and input, as well as the beginning
prompt and exit prompt, from these four commands

df -hlT
cat /etc/fstab
uname -a
lsb_release -sircd

copy/paste the in/output back to this thread using the instructions


And please the output of

fdisk -l


/dev/sda Fujitsu MHW2120B 111.79GB.

can’t be true. /dev/sda represents a device, not a partition.

Quite true. sda would indicate the first SATA drive. sdb would be the second, and so on. sda1 would be the first partition on the first disk/drive. Learn Linux, 101: Hard disk layout

hcvv, I know you already know this, so just adding reference and clarification/further explanation.

This did get me currious. I do know that the partitioning does it by the device ID, which the OP kindly provided in the first post, MHW2120B. I simply took this and put it through Google. Google does provide a lot of hits all pertaining to the ATA SCSI drive belonging to Fujitsu. The 120B in the ID is how large the drive is; 120GB.

On 06/15/2013 06:36 PM, hcvv wrote:
> And please the output of
> fdisk -l

lol! of course…i thought i had asked for that…


My guess (but I hate guessing, thus I asked for further information) is that the OP thinks that sda is a partition and thus adds sda+sda1+sda2+,… getting about double the space. :frowning:

And 120GB is about 115GiB.

By the way, to the OP, the only way to “remove an alien partition” would be to physically remove the drive.

  • Fujitsu MHW2120BS* 5.4K Extended Duty SATA Hard Drive

Also now seeing “id: ee” which believe is the EFI GPT boot point.

When left my new mobile Samsung s4 mobile plugged into USB to recharge, then did a reboot without removing, opensuse 12.3 recognized it as just another mounted and active partition on my computer.

When I tried to remove thisFujitsu-MHW2120Bexternal device , partition or what ever it is, my computer crashed.
I have now tried to repartition my laptop but it won’t let me create a root partition.
Above is the page I getbefore I re-start the installation.

My internal memory is 120GBbut my partitioning shows me there is 192GB more than what I have.
Yesterday I bought anexternal drive which is 1.82TB & have connected it to my laptopfor extra space.
I have tried to totallyremove vista.
When I start up my laptopget the windows page which says F1 help, F2 bios etc then it goesdirectly to my Open Susse start up page.

Paul parker wrote -

FujitsuMHW2120BS5.4KExtended Duty SATA Hard Drive

Alsonow seeing “id: ee” which believe is the EFI GPT bootpoint.

Whenleft my new mobile Samsung s4 mobile plugged into USB to recharge,then did a reboot without removing, opensuse 12.3 recognized it asjust another mounted and active partition on my computer.

I used to view cctv footage on my laptop at work & connected it to a 2TB samsung DVR but then I was only using vista.
It is possible that someone could have connected an external device to my computer without my permission when I used to use it at work but why would linux pick it up now, after I have re-formatted it & removed windows?

Sorry for distracting you.

Believe people waiting for information DenverD requested in post #2 so can resolve your problem.

Sorry for the delay, my computer is running at snail pace -10.

 linux@linux:~> df -hlT
 Filesystem Type Size Used Avail Use% Mounted on
 devtmpfs devtmpfs 445M 40K 445M 1% /dev
 tmpfs tmpfs 470M 88K 470M 1% /dev/shm
 tmpfs tmpfs 470M 3.1M 467M 1% /run
 /dev/sr0 iso9660 928M 928M 0 100% /livecd
 /dev/loop0 ext4 3.4G 3.0G 413M 88% /
 tmpfs tmpfs 470M 0 470M 0% /sys/fs/cgroup
 tmpfs tmpfs 470M 3.1M 467M 1% /var/lock
 tmpfs tmpfs 470M 3.1M 467M 1% /var/run
 linux@linux:~> cat /etc/fstab
 devpts /dev/pts devpts mode=0620,gid=5 0 0
 proc /proc proc defaults 0 0
 sysfs /sys sysfs noauto 0 0
 debugfs /sys/kernel/debug debugfs noauto 0 0
 usbfs /proc/bus/usb usbfs noauto 0 0
 tmpfs /run tmpfs noauto 0 0
 /dev/root / auto defaults 1 1
 /dev/disk/by-id/ata-FUJITSU_MHW2120BH_NZ1DT772YE4U-part5 swap swap defaults 0 0
 linux@linux:~> uname -a
 Linux 3.7.10-1.1-default #1 SMP Thu Feb 28 15:06:29 UTC 2013 (82d3f21) i686 athlon i386 GNU/Linux
 linux@linux:~> lsb_release -sircd

 linux@linux:~> fdisk -l
 Absolute path to 'fdisk' is '/usr/sbin/fdisk', so running it may require superuser privileges (eg. root).

 linux@linux:~> /dev/sda Fujitsu MHW2120B 111.79GB.  
 bash: /dev/sda: Permission denied

BTW am NON-Technical.

Your device /dev/sr0 appears write-protected, mounting read only, and using the openSUSE-Live version.

results from lsb_release -sircd may confirm this.

Is your openSUSE-Live-CD disk in DVD/CD drive still, or on a ram-chip still plugged into your computer at moment ?

IF yes, your computer may be slow as is using your RAM to hold openSUSE-Live-DVD operating system possibly swapping data from the openSUSE-Live-DVD from time to time.

Test this by removing dvd/usb then restarting.

IF you wiped your hard drive with no OS it will do little, other than confirm hard drive clean.

Then plug the dvd/usb back in then restart when should load again. (Clearing files in ram)

Your code result for **fdisk -l **suggests you are not logged in as root user.

my highlighted commands for when first logged in as simple user, second logged in as root :

paulparker@linux-bnn6:~>** fdisk -l 
**Absolute path to 'fdisk' is '/usr/sbin/fdisk', so running it may require superuser privileges (eg. root).
paulparker@linux-bnn6:~>** su -**
linux-bnn6:~ # **fdisk -l**

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sda: 500.1 GB, 500103634432 bytes
255 heads, 63 sectors/track, 60800 cylinders, total 976764911 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048    16771071     8384512   82  Linux swap / Solaris
/dev/sda2        16771072    58718207    20973568   83  Linux
/dev/sda3   *    58718208   101707775    21494784   83  Linux
/dev/sda4               1           1           0+  ee  GPT

Partition table entries are not in disk order
linux-bnn6:~ # 

My understanding of openSUSE-Live-DVD was for it to demonstrate openSUSE rather than intend be used as an installation disk, while also giving you root access on terminal.

At terminal type **su -
IF asks for password and you set one, type it in, IF you did not set a password just press enter.

IF you see incorrect password you know a password exists.


 paulparker@linux-bnn6:~> **su -** 
**su: incorrect password**

IF access as root user try command fdisk -l
then post the results.

Read earlier of some people attempting to install from openSUSE-LIve-CD, some experiencing problems, including establishing the root user password.

Leave advice about this to those of better knowledge.

I tried to remove the DVD & got a black screen.
I re booted my laptop & managed to ran the live version from the icon on my desktop running

As soon as it is stable I will download the full version to DVD.
My part has a 64 bit OS & has 12.1 installed on it.
I tried to use her DVD but it didn’t work on my laptop which is a 32 bit.

So am I understanding you right, you have installed the Live version to your hard disk now?

You don’t have to download and reinstall the full version then (the only difference is that there are more software packages on the DVD, but there are even more in the online repos). Just add missing software with YaST or zypper.
The online repos should have been set up correctly by the Live Installer.

My part has a 64 bit OS & has 12.1 installed on it.
I tried to use her DVD but it didn’t work on my laptop which is a 32 bit.

Of course, the 64bit version won’t run on a 32bit cpu. That’s why it is called “64bit”.:wink:

Need you post your results from command fdisk -l so learn how your hard drive was partitioned, then if and where openSUSE installed on it.

On 06/16/2013 02:26 AM, Hermes14 wrote:
> --------------------
> linux@linux:~> fdisk -l
> Absolute path to ‘fdisk’ is ‘/usr/sbin/fdisk’, so running it may require superuser privileges (eg. root).

Note to helpers: Always assume that a new user is unlikely to be running
commands as root, nor should they be. Always give them the user version of the

To the OP, the command should be

sudo /sbin/fdisk -l

I agree with the observation above that you have a second disk plugged into your

When I tried to open the terminal my laptop froze.
A message came up telling me there were updates that needed to be installed.
If it doesn’t come right in say 30 min I will try ctrl + alt + del & reboot.

I think the problem is I haven’t defined a root partition.
It will let me create a partition but doesn’t give me an option to create a a root partition.
I have two partitions in ext4 format.

While doing updates I received this out of disk space. (photo of my screen is below)
It doesn’t say which partition but I have got a good feeling it it my root.
I clicked okay & it took to Yast.
At the moment I am loading some library file & it seems to be okay except I keep getting this message
"System management is locked by the application pid 3996 close application.

Yes the live version is installed to my hard disk but as soon as I remove the DVD my system crashes.
I am hoping the updates will rectify this problem.