How do you access a usb drive plugged into my BT Home Hub 3(router)

Can anyone please give me simple instructions how to access a usb drive which is plugged into my home network(BT home Hub 3) As I can access the drive in Windows XP, using Windows Explorer, I assumed I would be able access it using Dolphin in OpenSuse 13.1. Although I can see the drive in Firefox and am given the option to connect or safely disconnect the drive I have completely failed in finding how to access in Dolphin. Any help gratefully received. merkland.

Hi merkland, As you can access your network attached USB Drive using Windows XP Windows Explorer, I assumed your router shared your USB Drive using SMB. But next you lost me:

Are you saying that you can access the USB drive contents from Firefox? Or that from the router administration web page you can see the USB drive is connected to the router?

I am saying I can see the drive in Firefox but cannot access its contents The only function I can perform in Firefox is to “safely disconnect the drive” or “connect” the drive.


In that case a simple “smb://your_hub’s_hostname” in dolphin’s address bar should be worth a try. If it IS sharing that Drive with SMB, it should show up, shouldn’t it?

If your user is created on that Hub you can SSH into it. Either on CLI or if you like dolphin, you can use “fish://your_hub’s_hostname” in dolphin’s address bar. Then you need to find the directory where it is mounted. That used to be


but I have heard that the path has been moved somewhere else.

Might have to check where to…

Edit: may be something like “/run/media/user/”



Sorry but you are dealing with an old ignoramus here who is incapable of getting to grips with the command line or jargon - what is SMB, SSH, and CLI?
I did say at the beginning “simple instructions”. I can usually manage quite well with a Graphical User Interface so taking a stab at what you say above, you mention dolphin’s address bar but dolphin does not normally have an address bar unless you use the find button. Did you mean to say dolphin or did you mean firefox which does have a command line?
Reverting to Dolphin, down the left hand edge of the screen it has a column headed “Places” and under this the list begins Home, Network, Root, Wastebin, … I expected to be able to access my router under “Network” but it does not appear there and I have been unable to add it there. I tried the help facility but I am obviously too ignorant as it was no help to me!
Assuming it is possible can someone please give me simple instructions on how to add my home network to the “Network” folder?


For starters, I am assuming this is BT as in British Telecom. You need to realize that default functionality of routers tends to be very provider specific. It is possible that only some other openSUSE user with same BT router and service will be able to replicate your set up and help debug.

Here is just a guess, based on your comment that you can reach the drive from WinXP, presumably using Windows Explorer, a.k.a File Manager.

A piece of useful infor to learn/remember. SMB is the protocol used by Windows Networking. Samba is the Linux implementation of that protocol and enables Windows and Linux clients to exchange information over the network.

Try this - Open Dolphin, select Network under places, then click the “>” to the left of Samba Shares and wait a bit. When you first open this, the Samba process scans your network for available network shares. The “>” should change to a “v” and a tree structure display under Samba Shares.
The specifics of what you see will depend on default settings across your network, here is what I get on my 12.3/KDE 4.11.4 system
Capenet is my network name, below it are a couple Linux Servers running Samba and a WinXP Virtual Machine, all sharing various folders. In my case, Dd-wrt-cape is my router. You will have to explore your setup, as it will likely be different.
Be aware that since Windows and SMB are rather sloppy with Upper/Lower case, names may not appear EXACTLY as you might expect.

If a USB were mounted under my router, I would expect to see it in the tree below Dd-wrt-cape.

Hi merkland,

I did say at the beginning “simple instructions”.

So sorry. Usually I have the feeling I am the one who is a bit behind.

My idea about ssh wouldn’t work. That is a way to remotely log into another device. If that is a DSL-router (I didn’t know what BT Home Hub 3 exactly is) then you probably don’t have any user credentials to log into that machine.

Still, it would be good if you could find out the “hostname” of your router, maybe from the graphical user interface or the manual? Then you can try one more thing.

The “>” is the address bar, only, it doesn’t look like one. Right-click on it and you can change the normal appearance from “navigate” (what is the “>”) to “edit” (what is you see in cmcgrath5035’s example).

I have a fritzbox as router and just tried cmcgrath5035’s advice. Interesting, my routher doesn’t appear via network / places as cmcgrath5035’s described below. But…

If I enter “smb://hostname” it shows up. So, if cmcgrath5035’s way doesn’t work for you, you can try that with the hostname of your router.

Best regards


Edit: I have just re-tried via the network folder, now it showed up behind the “workgroup” icon. I am pretty sure it didn’t before, but that doesn’t matter anyway.

tip: While in Dolphin hit ctrl-L

You can access the BT Hub by entering:


In a browser. The settings are password locked, IIRC the default password is “admin” unless you have changed this yourself.

I have just done this myself. In Dolphin go to:
View>location bar>Editable location and check the box…

(Or you can tap F6 in dolphin)

Then type in:


This will resolve to a smb: address, and show the contents of your USB drive



If you want Dolphin to always show the editable location bar,
In Dolphin: Settings>Configure Dolphin>Startup
You should then see this

Check the box there…

Very many thanks everyone who have attempted to help me.
Your efforts have not been in vain as I can now report 100% success.
Not only can I access the USB drive and the files on it but I can do it in two different ways through Dolphin!!
All I have to do now is remember how it is done!

Again very many thanks.