How do I use bluetooth headphones?

I purchased bluetooth headphones.

I was able to pair. It shows as an audio device. But I cannot find a way to direct ordinary sound output to these headphones.

If I check Audio settings, it shows either “line out” or “headphones” (if wired headphones are plugged in). But I cannot find an entry for the bluetooth headphones (JBL TUNES 510BT).

What am I missing?

@nrickert Are you using pulse-audio or pipewire?

I think it is pipewire – or some combination of both.

@nrickert what output from wpctl status then?

% wpctl status
PipeWire 'pipewire-0' [0.3.64, rickert@nwrdell, cookie:3091056803]
 └─ Clients:
        31. xdg-desktop-portal                  [0.3.64, rickert@nwrdell, pid:2713]
        32. WirePlumber                         [0.3.64, rickert@nwrdell, pid:3132]
        33. WirePlumber [export]                [0.3.64, rickert@nwrdell, pid:3132]
        37. wpctl                               [0.3.64, rickert@nwrdell, pid:31597]

Audio
 ├─ Devices:
 │  
 ├─ Sinks:
 │  
 ├─ Sink endpoints:
 │  
 ├─ Sources:
 │  
 ├─ Source endpoints:
 │  
 └─ Streams:

Video
 ├─ Devices:
 │  
 ├─ Sinks:
 │  
 ├─ Sink endpoints:
 │  
 ├─ Sources:
 │  
 ├─ Source endpoints:
 │  
 └─ Streams:

Settings
 └─ Default Configured Node Names:
%

That changes to:

Audio
 ├─ Devices:
 │      37. JBL TUNE510BT                       [bluez5]
 │  
 ├─ Sinks:
 │  *   38. JBL TUNE510BT                       [vol: 0.73]
 │  
 ├─ Sink endpoints:

(I’m showing just the changed lines). That’s with the bt device connected.

@nrickert But nothing like this…

Settings
 └─ Default Configured Node Names:
         0. Audio/Sink    bluez_output.XX_XX_XX_XX_XX_XX.1

I don’t know where I would configure that.

I should have mentioned that I am using KDE as desktop.

Hi. Can you make a snapshot of the audio widget? You said you see two options there.

@nrickert maybe @deano_ferrari can help or @oldcpu ??

I posted such a snapshot in an earlier thread. It has not changed since adding that bluetooth device.

I seem to have options to direct the audio to a surround sound device (which doesn’t actually exist), but no option to send to the BT device.

My system is in Galician, but these snapshots show my audio settings using bluetooth headphones.

https://paste.opensuse.org/b49a37e4912e
https://paste.opensuse.org/de26c28acd74

If you click the audio in the KDE panel the bluetooth headphone will be in the selection if it is connected.

See the last available audio in the list, it is a bluetooth earphone.

But it’s not there.

The equivalent screen here shows only “Line out” and “Microphone”. If I plug in wired headphones, then “Line out” changes to “Headphones”. But the BT device never shows up. However, click on BlueTooth does show that it is connected.

Frustrating.

hi
Do you have the “bluez-auto-enable-devices” package installed?

4 Likes

Thank you. No, that wasn’t installed. And installing seems to have fixed the problem.

I’m intrigued that installing that package helped on it’s own, as it only provides /etc/bluetooth/main.conf (a totally commented file). Did any other (bluez-related) packages get installed at that time? Anyway, main.conf is used by bluetoothd on startup. It contains a lot of configurable options…

https://wiki.archlinux.org/title/bluetooth
https://pythonhosted.org/BT-Manager/config.html

You are correct – that file is all comments.

But perhaps installing the package runs a setup script which did what was needed.

The package doesn’t contain anything other than the file mentioned, and a basic script to restart the bluetooth.service. Anyway, good to read that your BT headphones are working for you.

I had the same problem with the headphones and speakers. I installed the package and it is solved. I don’t remember if I installed any other bluez package.