how do i trackdown a crash in y2controlcenter?

christopher@SCOOTER:/usr/lib/YaST2/bin> su -c /usr/lib/YaST2/bin/y2controlcenter
QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0
Segmentation fault (core dumped)

also when i use kdesu within kde, it dies silently on start

christopher@SCOOTER:/usr/lib/YaST2/bin> kdesu /usr/lib/YaST2/bin/y2controlcenter

this also happens from kde GUI as well, when i click on yast in Application menu, i get the kdesu dialog then the yast controlcenter dies silently on start

Any particular reason your running it like that? The /sbin/yast2 script sets up environment variables etc. If you look at the desktop file is starts with;

/usr/bin/xdg-su -c /sbin/yast2

Try your command with the xdg-su -c instead…

for troubleshooting i ran the app like normal and wanted to track down why yast crashed, so i tracked down how it worked, what is interesting running the individual yast utilities do not crash only the control center does

No crashes here on GNOME with YaST control center… bug report time then :wink:

I see the same warning about wrong permissions displayed but instead of a segmentation fault am able to launch what is likely a read-only Yast2.

I guess the real question might be why you’re launching the y2controlcenter specifically instead of launching Yast2?
For instance the following launches with no errors or warnings for me (after providing password)

su -c yast2


Slight modification,
Only after I closed Yast2 did the warning write to stdout.

But, as I described for me it’s only a warning and did not prevent Yast2 from launching or functioning properly.