How do I speed up logging in for Tumbleweed and Leap?

Hello,

I have a multiboot system with a dual-core 64-bit AMD CPU and 6 GB RAM. All operating systems are 64 bit. I noticed that on my PC, Debian Stretch RC3 is the fastest to show login screen, whereas it takes 3-4 minutes from the time I select openSUSE Tumbleweed on Grub menu to the moment sign-in screen appears. Leap is only a little bit faster than Tumbleweed in terms of this time.

How do I speed up the process? Any suggestions?

Thanks a lot for your help.

Hi
Open a terminal and check out systemd-analyze command;


systemd-analyze
systemd-analyze blame |head -n 10

That should identify potential slow startup

Hello malcolmlewis,

Here are what’s being shown on my terminal’s screen:


uname -a

Linux linux-0686 4.10.12-1-default #1 SMP PREEMPT Fri Apr 21 11:50:25 UTC 2017 (3043bd9) x86_64 x86_64 x86_64 GNU/Linux


systemd-analyze

Startup finished in 2.756s (kernel) + 5.072s (initrd) + 3min 3.459s (userspace) = 3min 11.287s


systemd-analyze blame |head -n 10

          7.392s wicked.service
          6.844s dev-sda5.device
          6.392s systemd-journal-flush.service
          3.620s SuSEfirewall2_init.service
          3.208s postfix.service
          2.244s display-manager.service
          2.220s systemd-udevd.service
          2.180s ModemManager.service
          2.120s SuSEfirewall2.service
          1.844s logrotate.service

It appears I don’t need postfix.service, ModemManager.service and logrotate.service. How do I delete these services?

Thanks for your quick reply.

Oh, I forgot to ask what other services I probably wouldn’t need and therefore can eliminate as well.

Thanks for your help.

:wink:

Hi
Use systemctl command, so is wicked using dhcp, does the other system use dhcp? Is this just ipv4 or 6 or both?

I just use ipv4, so set postfix configuration to use inet protocol ipv4

To dsable/check a systemd service;


systemctl status <some service, target etc>
systemctl disable or stop etc.

Hello malcolmlewis,

For now I only used DHCP IPv4. How do I set postfix configuration to use inet protocol ipv4?

Thanks again for your help.

Hi
As root user, edit the file /etc/postfix/main.cf and around line 674 change;


inet_protocols = all
to
inet_protocols = ipv4
systemctl restart postfix
systemctl status postfix

Hi
Also fire up YaST and in System -> Network Settings on the Global Options tab, deselect the Enable IPv6 check box.

Since your using dhcp with wicked, consider setting a static ip address outside your dhcp range.