How do I set vlc as the default video player?


I just reinstalled my laptop with OpenSUSE 11.4, 64-bit and I’m using gnome 3.0, and it looks great. I can’t figure out how to change the default video player to vlc though…

I’ve tried going to ‘Applications’ → ‘System Tools’ → ‘System Settings’ → ‘System info’

Here I can choose default programs, however vlc does not appear in the drop-down menu for videos. I do have vlc installed. I can choose to play videos with it when I right-click video files. But I’d like vlc to be the default so that I can just double click the video file and vlc plays it.

It is a little bit confusing as totem is set as the default video player in the above-mentioned window, but when I double click a video file banshee starts…


Try running on a console with your normal user:


I don’t use gnome 3 but, do you see browse option somewhere near, Maybe you can browse and select vlc player.

Using that I get the following message:

jacob@linux-z740:~> gnome-default-applications-properties
If 'gnome-default-applications-properties' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf gnome-default-applications-properties

There is no browse option in that window I mentioned. I just rechecked it…


I’m logged into something else (Unity), but I will take a look within the hour and let you know.

Right click the multimedia file > Properties > Opens With

According to the developers of VLC: How to make VLC the default player - VideoLAN Wiki