How do I set locale

And then what is the status of the link I gave?

That seems to be a custom locale definition that somebody created.
As I wrote, you can define whatever custom locale you want.

But the important point here is, en_DE is not defined on a standard installation.
Take a look into /usr/lib/locale/…

That is already clear since @karlmistelberger showed it.

The variable en_DE can be found in KDE’s system settings under Region -> format. There are also several other cases that have english as a language and another country as region. For example you have en_FI and en_SE (the last one could be en_SV, I’m not by my computer and so can’t double check).

From a non-technical user’s point of view, I don’t know how I am supposed to know that en_DE doesn’t exist when you can set it as your locale system settings.

If it doesn’t exist, then it ought to be removed as an option in KDE system settings. Otherwise, other users might run into the same problem.

Well, then what are we still discussing here?

If a locale is not defined on the system, it won’t work.
Even if it is a standard one like de_DE.

I’ll try the above when I’m back at my computer.

Wen I get back home, 'll try to set the format to de_DE via LC_TIME and LC_NUMERIC and at the same time have en_US set as language. What I want to have is this:

Time: Sunday, 27 August 2017 15.02
Currency: 24 €

The above is the example given in KDE system settings when choosing en_DE.

Ok, I just found out that en_DE (and other en_XX variants) actually have been added to the CLDR (Common Locale Data Repository) database about 2 years ago:
(as a result of )
So apparently it is indeed a standard locale meanwhile.

But still, it’s obviously not defined (yet?) in openSUSE.

Calligra words:

  • I tried to open the file with Calligra by right-clicking on the file and in the context menu -> open with -> Calligra words, but now it can’t open it. It loads the file up to 99 % and the just stalls. Don’t know why it wont open, when it just a couple of days ago it worked fine.
  • When I try to open the file through the menu dialogue (File → Open file… → Att_göra.odt) nothing happens.


  • When I click on the file, I get the following message:
/home/brahmavihara/Documents/Att_g??ra.odt does not exist.
  • When I go through LO’s menu dialogue, I get the same message but this time with the correct character
/home/brahmavihara/Documents/Att_göra.odt does not exist.

When I open Dolphin and single click on the file, I can see the contents in the Dolphin’s preview.

In KDE’s system settings -> Regional settings -> Formats, you can pick en_DE. There are also several similar options for other regions, for example en_DK, en_SE, en_FI, en_NL, en_IL, en_SI. So, what’s listed in KDE’s system settings doesn’t mirror what’s available in YAST. From a non-technical users point of view, it’s not obvious that it is not supported.

I forgot to mention that when I switched locale in KDE’s system settings to sv_SE (Swedish in Sweden), then I could open the file with LO. But I couldn’t open it with Calligra Words. I even switched the language setting to Swedish but Calligra still wouldn’t open the file.

GUIs are complex. Try a simple example:

karl@erlangen:~> export LANG=sv_SE; calligrawords Att\ göra.odt

  • The above works on my machine perfectly with Att\ göra.odt being a valid document.
  • Valid locales are installed at /usr/share/locale/ independent from what KDE settings suggest.
  • setting the locale via KDE settings may require logging out and logging in again to become effective.

I opened YAST -> /etc/sysconfig Editor -> System -> Environment -> Language.

From there, I went through RC_LC_NUMERIC, RC_LC_TIME, RC_LC_MONETARY. The “Setting of” for each of these was empty. When I clicked on the dropped down for “Setting of:”, it was also empty. I couldn’t choose anything.

The only ones that were predefined and had values/options in the dropped down were:

INPUT_METHOD was also empty, but in the dropped down there were several values/options I could choose.

Any ideas, suggestions what I could try?

/etc/sysconfig Editor -> System -> Environment -> Language sets the default language on login. This value is written to file /etc/sysconfig/language. You may input any value for RC_LANG.

NOTE: Forget about the drop down list.Only values listed by the command locale -a will result in some useful setting for default of LANG. To see some effect you need to logout and login again.

To get an idea what the effect really is try to set RC_LANG to sv_SE, log out and login again. Language of your graphical session will change to swedish.

Right. The config module obviously shows a static list (probably taken from CLDR) and doesn’t check whether the locales really exist in the system.
Feel free to file a bug report on about this, but I think there already is one (at least a bell is ringing deep inside my head, I think I saw one some time ago but I’m not sure).

but why not use en_US as locale and DE as region?
I get it that there is an en_DE locale whose reason for existence I don’t quite understand as en_US and en_UK (or en_AU) are different locales some words are spelled differently en_DE is what en_US in DE?
about the display issue in konsole I still think it’s a font issue it might be a corrupt font file or a resource bug upstream why not test it with a different font, I remember 13.2 had a missing gtk2 visual style in the default adwaita package afaik nobody reported it and it wasn’t fixed my point being file corruption does happen, a question does Dolphin or Nemo (or what ever) display the proper name of the odf document?

Tumbleweed comes with an archive of locales, Archlinux generates them as needed: Tumbleweed can also generate and install new locales. Anyway different sets in KDE and glibc-locale are confusing. Not all applications support all locales.


I have mixed results. I used the command a couple of days, and Calligra opened with an empty page. Tried with different files that had åäö and it opened also with an empty page. I also tried the command from the same folder that file was in. Should I be expecting that calligra opens the file with the content, or is it just opening a knew file?

But, I tried the command again just now, and this time Calligra wont open. It just stalls and my cpu goes up to 100%. Something weird has happend to Calligra. It can, though, open other files that don’t contain åäö.

I tried the comman locale -a and noticed that there are formats that mix regional format with english, e.g. en_DK, en_DK.UTF-8, en_IL. I’m thinking that if there is en_DK, why shouldn’t there be en_DE. In other words I’d like to propose that Yast includes these other regional formats that use en_* (as in en_DE, en_SE, en_FI etc).

I see. If I file a report and it gets fixed, will I then be able to select en_DE?

I’m guessing that it would only partially solve the problem, namely that the two settings applications (KDE system settings and YAST) show the same info. But considering that en_DE and en_SE, en_FI etc are a standard, wouldn’t it be better if Yast included those regional locales?