How do I rotate desktop cube on openSUSE 42.1 Plasma 5

I have configured the Desktop setting for the desktop cube and created four virtual desktops. Currently I can switch between desktops using keyboard shortcuts but I would like to adjust the size of the cube and rotate between virtual desktops. What setting do I need to active to make this work properly?


You are using kwin5’s as a desktop manager because there are other ways to get the cube too?
You can do it by using the mouse wheel (just click on an empty part of your desktop and use the wheel)
or by clicking on any of the 4 desktop thumbnails in the task-bar

I can use the wheel to move from one virtual desktop to another but the cube does not appear. To make changes to my desktop I use the system settings options and their is a Desktop Behavior option and Virtual Desktop which is where I chose desktop cube as my switcher. Am I missing a step?

Should be Configure Desktop - Desktop Effects - All Effects be sure that the cube is checked you can also adjust settings there

Here ctrl F11 triggers it

You should also be able to set hot corners to click the cube on

Configure Desktop - Workspace Behavior - Screen Edges

Note running 13.2 so some things may have changed but that is the general idea

I’ve always used the mouse wheel to rotate the cube I didn’t know about the keyboard shortcuts, as gogalthorp said check and see if effects are off.

I_A, The keyboard shortcuts are simply CTRL F1-F4 to switch to the corresponding desktop or I also have CTRL L to switch left and CTRL K to switch right. Anyway, I have looked in the Desktop Effects list and I have no Cube option to turn on but I do have Fade and Slide as Virtual Desktop Switcher options.

gogalthorp and I_A when I try to setup the screen edges or corners the cube options are grayed out. So it seems that I have an option that I still need to turn on. I will keep looking than you for the help and let me know if you have any more ideas.


I have looked in the Desktop Effects list and I have no Cube option to turn on but I do have Fade and Slide as Virtual Desktop Switcher options.

Above Fade and Slide (under VD Switching Animation) you should have ‘Desktop Cube Animation’ and below that, under Window Management >> Desktop Cube

I was able to find the Desktop Cube and Desktop Cube Animation after making them unhidden. The whole problem was the drivers for my video card had to be updated. I am using a NVidia card so I had to install the proprietary drivers to enable the 3D animation.

Sounds reasonable. I had a problem with the cube thing recently after attempting to install Megaglest (a game). Have since removed it, but I thought that the 3D effects were not working. Turns out the speed was set at 10ms, which is too fast for the eye to see it. Reset the speed to 500ms and everything is cool.

In my case, you might say that the biggest problem is the fool sitting in front of the screen. lol!

I definitely know that feeling, I have spent hours working on different changes to projects or desktop settings just to come back a day later and find the answer right in front of me. We call that a PBKC error (Person Between the Keyboard and Chair) and I fall into that category on occasion.