How Do I roll back to previous image?

Hello, I recently updated my system using the Built in Updater.
Previous to upgrading Leap 15.3 was trying to push an update that kept failing with this message.

the to be installed patch:openSUSE-2022-109-1.noarch conflicts with 'libvlccore9.x86_64

I noticed that libvlccore9.x86_64 was associated with Kaffeine player and I believe that was conflicting with VLC.
So, I removed Kaffeine and rebooted and then did the updates via “Yast Online Updater”. The updater still found some conflicts with VLC and/or Kaffeine and I told it to remove some stuff. I think it was getting mixed info between pacman repos and the SUSE repo’s or something.

After I did this the system got hung rebooting. I then tried rebooting but was unable to get it to boot.
It was hanging up saying something like this>

huh, entered softirq 0 HI … “something.something”

So I used advanced boot and was able to get it to boot up by manually selecting the 59.87 preempt or the 59.87 default. I already went in and removed a few snapshots but I’m worried I might brick something if I remove anything else. Here’s what I currently have in Yast Admin “File System Snapshots”. I want to remove the 59.90 preempt and default and just boot off 59.87 so I can try to get my updates applied correctly.

I don’t believe I should just delete these out of my /boot? Unbootable >

-rw------- 1 root root 17781676 Aug 26 10:19 initrd-5.3.18-150300.59.90-default
-rw------- 1 root root 17775892 Aug 26 10:19 initrd-5.3.18-150300.59.90-preempt

I greatly appreciate any advise on how to do this.

Details of how to “rollback” to a previous snapshot is documented here:

Hi Paul, thanks for this info. Maybe I didn’t phase this correctly. I just notice I’m not booting off a “read-only” snapshot. When I boot up I choose > Advanced Boot Options > Then I select the 59.87 preempt or the 59.87 default in order to boot up.

I see a snapshots menu at the bottom but I haven’t been using that. So, I’m not sure about the Bootable snapshots. If I choose one of those snapshot and boot up successfully I suppose I could run this to try to recover?
sudo snapper rollback

Any other input is greatly appreciated since I don’t want to foul things up worse.

FYI, I found a “temporary” work-around by using Yast Boot Loader and changing the Default Boot section to 59.87 default.
Now when I boot it selects the advanced menu and then selects this image and boots up fine.
Now I just need to see if I can safely remove these two boot images or whatever they are under /boot

-rw------- 1 root root 17781676 Aug 26 10:19 initrd-5.3.18-150300.59.90-default
-rw------- 1 root root 17775892 Aug 26 10:19 initrd-5.3.18-150300.59.90-preempt

Any ideas?

Hello, I realized I have a new problem. When I choose Windows to boot off of in Grub menu I get this error and it wants to try and do different options. I tried changing to my Windows boot partition in BIOS and I’m greeted with the same message.

windows 10 0xc000000e

This error basically indicates Windows has a problem with the boot loader and gives a blue screen with different options I mentioned above. F8 For setup, Enter UEFI BIOS, etc.

I tried changing it back to how it was in bootloader options with the Top SUSE menu. I think I have to try to boot off Windows recovery drive and then run these commands.
bootrec /scanos
bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd

I’m probably going to try that but I was wondering if that’s going to overwrite the GRUB and prevent me from booting in SUSE? I’m not sure if a few of the smaller snapshots I deleted cause it to mess up the BCD boot loader?

Appreciate any additional pro tips before I try the recovery method above to get back into Windows 10.