How do I recover data from Plasma Vault?

My /root is on btrfs system that got corrupted and I can no longer boot to desktop.
I had a plasma vault set up and didn’t have a chance to back it up before the crash.

My home partition is fine and I can access it via live usb.

Question is - how do I recover data from the plasma vault? Is there a way to unlock/mount plasma vault from terminal? Or maybe plasma vault can be copied to another Plasma environment and unlocked there?

if your home partition is fine a reinstall (if you keep your home partition and the same user account) should keep your vaults
there is very little information information about plasma vaults online the only thing I could find was this redt post
you need to backup both the “~/.vaults/” folder and the “~/.config/plasmavaultrc” entry
or copy them on a running TW system (or a system with plasma 5.11+)

here is a good presentation on fixing btrfs:

Thanks for the link. Unfortunately, I’ve stumbled upon a post elsewhere saying to run “btrfs check --repair /dev/xyz” and I did… so btrfs fix got me nowhere. I had to reinstall.

Thanks, this gave me some clues. In my case, encrypted files were in ~/.local/share/plasma-vault/

I’ve tried transgressing it to live Leap 15 USB, but that didn’t work. I suspect that there is some other connection between a system or user account and a vault, not just a plasmavaultrc file. I base that on the fact, that once vault is created, even without any files placed in the vault, there is one file in ~/.local/share/plasma-vault/ folder, encrypted by the looks of it.

Also, I have created a test vault on Leap 15 Live USB and then transferred that vault to another user’s account on the same Live USB and it worked.

Finally, I’ve installed Leap 15 on top of my damaged TW, keeping the home partition, transferring user account and I was able to unlock my vaults.

Once again, thank you for the tips