How do I install DKMS kernel modules for proprietary NVIDIA drivers?

After having issues with the installing the Proprietary NVIDIA graphics drivers from here, I tried installing the drivers directly from NVIDIA’s website using their script. When installing, it said that compiling the DKMS kernel modules failed, so I installed it without the kernel modules. Proprietary graphics works fine now, however I need to install the DKMS modules to run virtualbox. Does anyone know of a good way to do this? I tried following this thread but it didn’t help.

I am running OpenSUSE 12.3 64bit, and NVIDIA drivers 325.08

Thanks for your help

You can do it, but several fixes are required including a compile of your own kernel, up to 3.10 as I recall. I can say that I use the open source driver when I can:

Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

DKMS & systemd - How to get Dynamic Kernel Module Support to work in openSUSE 12.1 - Blogs - openSUSE Forums

openSUSE and Installing New Linux Kernel Versions - Blogs - openSUSE Forums

S.A.N.D.I. - SuSE Automated NVIDIA Driver Installer - Version 1.00 - Blogs - openSUSE Forums

Here is some help on the subject. Read all before you try anything …

Thank You,

I tried S.A.N.D.I and I keep on getting this error

/usr/sbin/dkms: line 73: : No such file or directory

incidentally this is the same error that keeps me from being able to run virtualbox.

So you went straight to SANDI, but failed to install dkms from Packman.

Thank You,

I did, I have the packman repo installed and then did

zypper in dkms
Loading repository data...
Reading installed packages...
'dkms' is already installed.
No update candidate for 'dkms-'. The highest available version is already installed.
Resolving package dependencies...

Nothing to do.

Is this the wrong package?

Use this blog to get dkms working: DKMS & systemd - How to get Dynamic Kernel Module Support to work in openSUSE 12.1 - Blogs - openSUSE Forums

Thank You,

After doing a bit of research, it seems that dkms was in my system and working all along. The issue was that all of my dkms modules were either the wrong version or not configured correctly which made it seem to me that dkms was not working.

Thanks for your help.