How do I instal new PCI net work card

I was hit by lightning, it stopped the ethernet on my modem working so I got another one. Still no good so I got a gigabit PCI network adapter. The LEDs light up on the back of it but I do not know how to tell the computer to use it. I got a CD with several windows installations and a Linux one but all instructions are for widows and their tech support only new windows. I have opensuse 12.3 and can do a few things but don’t know a lot. I can see the card along with the onboard adaptor on YaST. The delete button does not light up with the old card but I can delete the new one but do not know how to instal it.

Please help me get off this windows lap top and back onto my desk top.:’(

Need to know a few things;

  • Do you use DHCP?
  • Are you managing it with IfUp or NetworkManager? ( YAST -> Network devices -> Network settings -> Global Settings, which is it Traditional IfUp or NetworkManager? )
  • What is the make and model of the new card?

Let’s deal with the old card first:
If you are managing it with NM, switch to Traditional IfUp, then go to Overview and “Edit” the old broken card, go to General and set Device Activation to “Never”, then Address and set “No Link”.

Then let’s configure the new card:
Then edit the new card and make sure the Address has “Dynamic Address DHCP IPV4 and IPV6” enabled if you use DHCP. Next, OK and reboot the system.

Using IfUp
The new card is Gigabit TG-3269 network adaptor
I can’t edit the old card (Gigabit RTL-8169) "Unable to configure the network card because the Kernal device (eth0, wlan0) is not present. This is mostly caused by missing firmware (for wlan devices). See dmesg output for details.

Yes use DHCP

If you edit the new card and set it to DHCP and don’t have a cable in the broken one, it shouldn’t matter.

After a bit of Googling the TP link card uses the Realtek RTL 8169/8110 chipset which should be supported in 12.3. You might need kernel-firmware package though.

The old card is RTL8169 the new one is TG-3269
I set the new card to DHCP next etc it didn’t work I tried this earlier. I did try some things with ROOT earlier but it didn’t understand any of the commands I found on a site.

For the new card it says:
Ethernet Network Card
Device Name:eth0
Started automatically at boot
IP address assigned using DHCP

There is nothing written or ticked in the Routing menu Should there be?

You don’t understand; the new card also uses the same chipset as the old one - the card can be called Humpty Dumpty but the only thing that matters is what chip is on the card :slight_smile:

If you open a terminal and type; ip addr

Does it show an IP for the second card?

Sorry I did what you said and did a print screen and saved as a jpeg on a portable drive and now can’t see how to attach it

:~> ip addr
1: lo <LOOPBACK,UP,LOWER_UP> mtu 65536 qdicc noqueue state UNKOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 brd 127.225.255.255 scope host lo
inet6 ::1/128 scope host
valid lft forever preferred_lft forever

I typed it but it removed the formatting

You can link it here; http://paste.opensuse.org/ (click on the image button)

Wonder if the persistent rules are somehow corrupted. First see if you can disable the onboard one from BIOS.

Then, as root, delete /etc/udev/rules.d/70-persistent-net.rules file and reboot. Then go to YAST and reconfigure the new card.

I’m sorry but I don’t know how to get to BIOS or how to disable onboard card.

To enter the BIOS, the most common way(s) is to press ONE of the following as your computer is booting up: F2 Del Esc

Thanks for that I got into BIOS I think. It says CMOS Setup Utility.
I can not find anything to shut network card down

I am considering loading windows 8 as I can’t get any help getting ethernet working and have spent a lot of time searching for answers
As a last resort I was going to try connecting to the USB port on my modem.