How do I get vlc plugin or other MM plugin's for Firefox?

KDE, Leap 42.1, & Firefox 45.0

I want to view direct feed from a webcam. When I login to the IP of the webcam I get the web interface which allows me to view live feed.
The live feed is expecting a VLC or Quicktime plugin. I see a black screen “no plug-in detected”.

I downloaded vlc from packman, switching repo’s. This did not help me.

I have searched for FF plugin for vlc or quicktime but don’t find any.

Chatting with another user of a similar webcam, they are running Mint and in FF have a ‘vlc multimedia plugin’ which was installed from the Mint repo.

If I go to sites that show highway web cams they also give an error for missing plugin.

What do I need to do to resolve this apparent configuration error.

Thanks, Jon

I downloaded vlc from packman, switching repo’s. This did not help me.

sounds like you have mixed packaes how did you switch repo’s?
did you do a zypper dup?
post your repo list

zypper lr -d

there are multiple multimedia plugins for firefox vlc is not the only one but I wouldn’t install other ones as it might cause problems
when you type
about:plugins
in the firefox address bar what plugins are listed?

I used the series of 3 commands you posted for another user.


sudo zypper ar -f ftp://packman.inode.at/suse/openSUSE_Leap_42.1/ packman
sudo zypper dup --from packman
sudo zypper in vlc-codecs libxine2-codecs

post your repo list

zypper lr -d
 1 | FGLRX_-_Leap            | FGLRX  | No      | ----      | No      |   98     | rpm-md   | http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_Leap_42.1  |        
 2 | download.opensuse.org-oss | Main Repository (DEBUG)  | No      | ----      | No      |   99     | yast2    | http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/ |        
 3 | google-earth      | google-earth    | No      | ----      | No      |   96     | rpm-md   | http://dl.google.com/linux/earth/rpm/stable/x86_64                  |        
 4 | my_updates      | my_updates                          | No      | ----      | No      |   95     | plaindir | dir:///home/jon/my_updates                                 |        
 5 | packman          | packman         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | ftp://packman.inode.at/suse/openSUSE_Leap_42.1/             |        
 6 | packman.inode.at-suse     | Packman Repository   | Yes     | (r ) Yes  | No      |   97     | rpm-md   | http://packman.inode.at/suse/openSUSE_Leap_42.1/    |        
 7 | repo-debug-update         | openSUSE-Leap-42.1-Update-Debug     | No      | ----      | No      |   93     | rpm-md   | http://download.opensuse.org/debug/update/leap/42.1/oss             |        
 8 | repo-non-oss              | openSUSE-Leap-42.1-Non-Oss          | Yes     | (r ) Yes  | Yes     |   99     | yast2    | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/   |        
 9 | repo-oss                  | openSUSE-Leap-42.1-Oss              | Yes     | (r ) Yes  | Yes     |   99     | yast2    | http://download.opensuse.org/distribution/leap/42.1/repo/oss/       |        
10 | repo-update               | openSUSE-Leap-42.1-Update-Oss       | Yes     | (r ) Yes  | Yes     |   98     | rpm-md   | http://download.opensuse.org/update/leap/42.1/oss/                  |        
11 | repo-update-non-oss       | openSUSE-Leap-42.1-Update-Non-Oss   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/update/leap/42.1/non-oss/            

when you type about:plugins
in the firefox address bar what plugins are listed?


OpenH264 Video Codec provided by Cisco Systems, Inc.
PackageKit
IcedTea-Web Plugin (using IcedTea-Web 1.6.1 (suse-1.2-x86_64))

OT: As long as I’m posting plugin’s, do I really need that IcedTea? Seems like it might be a security hole.

Thanks, Jon

I just installed npapi-vlc and tested it on a few local files and vlc opens avi and mkv files fine, firefox opens mp4 files with it’s build-in gstreamer interface,
in about:addons in the plugins tab did you set the vlc preference to always activate as it defaults to ask to activate, you can disable the java plugin here too.
The only thing I can think off is doing another dup to packman just to be sure all is fine and that a recent update didn’t restore an oss package
you also have two packman repo’s remove one (5 and 6 are the same)

sudo zypper dup --from 5
sudo zypper rr 6

I’ve never used Firefox for communication but afaik the build-in cisco plugin might be interfering so disable that one
http://i.imgur.com/D5jJLUm.png

  	 			 			 				when you type about:plugins

in the firefox address bar what plugins are listed?

 	 	OpenH264 Video Codec provided by Cisco Systems, Inc.
PackageKit
IcedTea-Web Plugin (using IcedTea-Web 1.6.1 (suse-1.2-x86_64)) 

you don’t have the vlc plugin installed, install it with

sudo zypper in npapi-vlc

sorry about the dual post as I always skip something when reading https://forums.opensuse.org/images/icons/icon12.png

Thanks, precisely what I was looking for. Now to test it out.
I previously had searched Packman w/ YaST for ‘vlc’ and the above did not show up.

I prefer to use YaST, I’m more comfortable with it even though I know zypper is, or appears to be, more efficient. I have simply never learned the syntax although I know how to find it. It’s easier to just use YaST.

The duplicate Packman entry in my repos is probably due to using a zypper cmd you posted earlier adding it to my list (different url).

Anyway, vlc is now in my add-on’s so hopefully I’m all set.
THANKS

I_A: Just confirming that the VLC plug-in worked perfectly!!

I have searched for a similar plug-in for QuickTime but have not found it. VLC does the job for me but the camera feed defaults to QuickTime so I thought I’d ask if you knew of a plug-in for that.

I would think that you wouldn’t need an other plug-in (for QuickTime) as vlc can play all the codecs.

As kerijan2003 said vlc handle’s quicktime files perfectly maybe you need to go in Firefox options->Applications search for mov or Quicktime files and set the vlc plugin as the preferred file handler.
That being said there are other Firefox multimedia plugins for linux for example the xine-browser-plugin, totem-browser-plugin…

Firefox handles QuickTime files natively maybe that’s your problem, if you want to use vlc instead of Firefox you’d need to disable Firefox’s internal mp4 decoder, go in about:config search for gstreamer and disable it.

The reason I ask is because when I go to the camera stream, it defaults to QT. I was looking to save two mouse clicks, changing QT to VLC on the camera interface. I asked because a Mint user said his FF had a plug-in for QT and he could select either. Maybe the camera interface is coded to look for the QT plugin even though vlc is supposed to play it. And vlc does not work (nothing happens, no error, no nothing) with the stream unless I change it to specify vlc.

Whatever, I’m very pleased that you got me up and running in vlc. It’s certainly not necessary to have a separate QT plug-in

I haven’t done anything like that so I don’t have expirience with camera streams but Firefox interal decoder seams to intercept QucikTime streams (mov and mp4) so the VLC plugin doesn’t get a chance to decode it, I’m not sure if dusabeling the internal mp4 (mov) splitter and decoder is a good idea but it can be done in Firefox advanced config, go to about:config search and disable both ffmpeg and gstreamer preferences, that will force the VLC plugin to do mp4 (mov) decoding but it might break some websites that stream in mp4 (youtube)

I used mp4 in my comments because the ITU-IT and ISO chose apple’s QuickTime mov container as the default container for mpeg4 so in principle an mp4 file is a mov file

I agree here, my request is not important enough to disable other features that may break who knows what further downline. It works great when I click a few times to select vlc rather than it’s default quickview.

jon