How do I get Tilp to recognize my calculator?

I have a TI-84 Plus SE that I would like to put some physics applications onto, but I cannot get it recognized in Tilp. When I launch Tilp via the terminal I get the following line at the end:

(tilp:2405): tilp-WARNING **: Attempting to communicate with calculator "none" !

When I am in Tilp, I can right-click on “none” and choose the option “Change Device.” In the Communication Settings I can see that it recognizes my TI-84, but it will not allow me to access it. When I select the device, the terminal provides the following output:

tilp-INFO: Opening cable null on port #1 to communicate with calculator none

(tilp:2405): tilp-WARNING **: Attempting to communicate with calculator "none" !

Any advice? If you have any follow up questions, let me know and I will do my best to answer them.

How are you connecting? If USB3 try a USB2 port

I have used both.

With it plugged try lsusb to see if the system sees it

I get the following output:

Bus 009 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
*Bus 007 Device 002: ID 0451:e008 Texas Instruments, Inc. TI-84 Plus Silver Calculator*
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 0461:4d20 Primax Electronics, Ltd HP Optical Mouse
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 2109:3431  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


(emphasis added)