How do I get jackd/qjackctl to work?

Exit status 256. I am trying to get Jackd to work. I think I have everything installed, or maybe I don’t. Never tried this before. I want it to work with Recordmydesktop.

So I installed qjackctl and this is the error it keeps giving me.

02:50:54.898 Patchbay deactivated.
02:50:54.900 Statistics reset.
02:50:54.911 ALSA connection graph change.
02:50:55.313 ALSA connection change.
02:50:56.912 Startup script…
02:50:56.913 artsshell -q terminate
02:50:57.358 Startup script terminated with exit status=256.
02:50:57.358 JACK is starting…
02:50:57.359 /usr/bin/jackd -dalsa -dhw:0 -r48000 -p1024 -n2 -C
02:50:57.361 JACK was started with PID=9345.
jackd 0.109.2
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
loading driver …
apparent rate = 48000
creating alsa driver … -|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
the capture device “hw:0” is already in use. Please stop the application using it and run JACK again
cannot load driver module alsa
no message buffer overruns
02:50:57.380 JACK was stopped successfully.
02:50:57.380 Post-shutdown script…
02:50:57.380 killall jackd
jackd(5157): Operation not permitted
jackd: no process killed
02:50:57.791 Post-shutdown script terminated with exit status=256.
02:50:59.609 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.

Is there anyplace that has a Suse 11.1 64bit explanation on how to get this working?

Any help will be greatly appreciated. Don’t be afraid to use big words, I have the plasma dictionary widget :wink:

Edit:KDE4.2.4/Plasma/Compiz, Suse 11.1 64, HDA Nvdia

I did add the audio group to my user account.

Looks like I am getting into the habit of posting and then figuring it out moments later. Wonder why that is, lol.

Problem Solved.

I unistalled pulseaudio, rebooted and all works fine now.

Update:

It wasn’t pulse audio causing the problem. It was pulseaudio-alsa that was. I had some issues with xine after I unistalled it all. I reinstalled it and forgot to check qjackctl and go from duplex down to capture only.

Nice threads you make lol!

They are more of a running report on what you are doing, then a real call for help. Nevertheless they do containt information for people doing about the same things as you :wink:

Good point, lol.

Might as well update this then.

I got everything to run without errors. So I assumed that RecordMyDesktop would record sound now with Jack, I was wrong.

I have been searching and looking but I am starting to think it has more to do with my HDA Nvidia card then anything else.

I can’t run pulseaudio without Xine getting cranky. I can’t run duplex in Jack without loosing all sound. I have tried all the obvious things and the less obvious things.

I can get it all running at the same time and working. recordMyDesktop picks up Jack. But for some reason the sound doesn’t want to go through anything, though the sound itself does work when I am running everything, just doesn’t want to record.

I am going to keep trying and post back here. There has to be a way to do this.

Though it might be easier to just go out and buy a cheap sound card that is more compatible with Linux.

suse amd64x2 adjusted his/her AFDB on Friday 24 Jul 2009 12:06 to write:

>
> Good point, lol.
>
> Might as well update this then.
>
> I got everything to run without errors. So I assumed that
> RecordMyDesktop would record sound now with Jack, I was wrong.
>
> I have been searching and looking but I am starting to think it has
> more to do with my HDA Nvidia card then anything else.
>
> I can’t run pulseaudio without Xine getting cranky. I can’t run duplex
> in Jack without loosing all sound. I have tried all the obvious things
> and the less obvious things.
>
> I can get it all running at the same time and working. recordMyDesktop
> picks up Jack. But for some reason the sound doesn’t want to go through
> anything, though the sound itself does work when I am running
> everything, just doesn’t want to record.
>
> I am going to keep trying and post back here. There has to be a way to
> do this.
>
> Though it might be easier to just go out and buy a cheap sound card
> that is more compatible with Linux.
>
>
Not sure if this will help:

Have you got the right audio capture source configured in the Desktop
Settings>Multimedia?

You can set different capture sources for different occasions.


Mark
Caveat emptor
Nullus in verba
Nil illegitimi carborundum

I just looked at the list. It is telling me that Nvidia analog is first, my tv card second and my digital card third.

Now this is wrong. For some reason when I boot and KDE4 loads it tells me it can’t run analog so it is going to digital. Since digital is third on the list then that may be the problem. I will give it a try shortly and let you know.

Well thanks. It was worth a shot. But that didnt’ help either. This is driving me crazy, everything I have read so far says this should be working.

I made this post specifically for recordMyDesktop not recording sound.

recordMyDesktop won’t record Audio - openSUSE Forums

which soundcard ?
I think this is the problem : the capture device “hw:0” is already in use

I have got the same error my sound card is delta 1010 with breakout box.

JACK requires the exclusive access to the sound device, and it doesn’t like
anyone else accessing the device before it.

Try to figure out which process is using the sound device by “fuser -v /dev/snd/*”. If it is pulseaudio.
try to run qjackctl from pasuspender, e.g.
% pasuspender qjackctl

You can also kill the process I use KDE 4.2 and had to kill kmix.
Ctrl+Esc search the process and end it (right mouse button).

Thanks for the info. I stopped working on this awhile ago. I plan on trying it all again soon and this will help.