How Do I edit xorg.conf to fix resolution and ignore EDID

I have return of problems with resolution changing due to repeating power failures during storms (and issues with KVM etc.) and am losing time trying to get resolution back to what I am used to.

If I use xrandr I get an asterisk by the resolution I think is correct (1024 x 768) but the actual resolution is showing as 800 x 600.

Is there a quick command to change this and how can I change more permanently.

Recommend you verify your display is working properly, making sure settings are correct and working correctly.
xrandr generally does a good job setting resolution, but is dependent on the display hardware it detects.

TSU

What output do you get from this command?

hwinfo --monitor

Hi Tsu,
The display is working fine but the problem is I am using an AdderLink remote extender to connect between display and computer. At present there are two machines with KVM switch which in turn connects to remote extender. I have no problems at all with the windows 10 device but problems with the Leap42.3 device. I cannot yet work out if the fault is with the remote extender or the Leap 42.3 device.

The way the system works is as follows:- When booting, the screen properties are not fixed and grub looks to the display for the EDID. In my case the display is replaced by an AdderLink X2 transmitter connected to Leap 42.3 and referred to as the ‘local’ transmitter.

The EDID info in the AdderLink X2 local transmitter is in turn read from the ‘remote’ transmitter which interrogates the display, but ONLY when being turned on. The remote AdderLink device stores this info for use when interrogated by the ‘local’ device.

The correct sequence when powering up is therefore to turn the systems on in the right sequence: 1st turn on display, then the ‘remote’ Adderlink box connected to the display, then the ‘local’ AdderLink box connected to the computer and then boot. If not done in this order the information passed to the computer on booting can be unreliable or invalid. I should add this is with an ADDER X2 device, others may work differently and sadly it does not always work correctly, particularly during power outages.

My first remedy is therefore to try and force the EDID to the correct resolution. I am not clear how to interpret my present xrandr reading but this is what it is:-

alastair@ibmserver2:~> xrandr
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 16384 x 16384
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 disconnected (normal left inverted right x axis y axis)
VGA-0 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00* 
   800x600       60.32    56.25  
   848x480       60.00  
   640x480       59.94  
alastair@ibmserver2:~> 


Any help or advice would be much appreciated.

Hi and thanks for picking up this problem. My problem is that I am working through a maze of devices so I cannot get a reply from hwinfo --monitor. Get nothing from this as reply flashes through and doesn’t remain on screen.

hwinfo --monitor > hwmonitoroutputfile.txt

Hi and many thanks again. Before your reply I went right back to beginning with only the one computer connected and started in the correct sequence. I was then able to select System Settings > Display and this gave me VGA-0 with all resolutions shown. I then ran xrandr again :-

alastair@ibmserver2:~> xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 disconnected (normal left inverted right x axis y axis)
VGA-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 553mm x 311mm
   1920x1080     60.00*+
   1680x1050     59.95  
   1280x1024     75.02    60.02  
   1440x900      59.89  
   1280x960      60.00  
   1280x800      59.81  
   1152x864      75.00  
   1280x720      60.00  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    66.67    59.94  
   720x400       70.08  
alastair@ibmserver2:~> 


This seems to demonstrate that display can be made to work once more and after some further messing around with my remote extender the mouse is working again have it all working with the desired resolution. (Until the next power outage!!!)
Moving on I am hoping you will be able to get this working once and for all. Here is the hwinfo --monitor result:-

ibmserver2:~ # cat hwmonitoroutputfile.txt
92: None 00.0: 10000 Monitor
  [Created at monitor.125]
  Unique ID: rdCR.SF7y3QEMc9B
  Parent ID: 4Ivu.Dxwnl4bsPHB
  Hardware Class: monitor
  Model: "ASUS PB258"
  Vendor: ACI 
  Device: eisa 0x25a1 "ASUS PB258"
  Serial ID: "FCLMTJ054496"
  Resolution: 720x400@70Hz
  Resolution: 640x480@60Hz
  Resolution: 640x480@67Hz
  Resolution: 640x480@75Hz
  Resolution: 800x600@56Hz
  Resolution: 800x600@60Hz
  Resolution: 800x600@72Hz
  Resolution: 800x600@75Hz
  Resolution: 832x624@75Hz
  Resolution: 1024x768@60Hz
  Resolution: 1024x768@70Hz
  Resolution: 1024x768@75Hz
  Resolution: 1280x1024@75Hz
  Resolution: 1920x1080@60Hz
  Resolution: 1280x1024@60Hz
  Size: 553x311 mm
  Year of Manufacture: 2015
  Week of Manufacture: 53
  Detailed Timings #0:
     Resolution: 1920x1080
     Horizontal: 1920 2008 2052 2200 (+88 +132 +280) +hsync
       Vertical: 1080 1084 1089 1125 (+4 +9 +45) +vsync
    Frequencies: 148.50 MHz, 67.50 kHz, 60.00 Hz
  Driver Info #0:
    Max. Resolution: 1920x1080
    Vert. Sync Range: 50-76 Hz
    Hor. Sync Range: 24-83 kHz
    Bandwidth: 148 MHz
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #39 (VGA compatible controller)
ibmserver2:~ # 


This tells me what you need to know but what I can do with it to get the right settings fixed needs your help please.
Regards,
Budgie2

What follows, saved to /etc/X11/xorg.conf, I expect to constitute a sufficient solution to your problem, assuming there is nothing in /etc/X11/xorg.conf.d/ that would override anything it contains.:

# 50-device.conf
Section "Device"
	Identifier "DefaultDevice"
EndSection

# 50-monitor.conf
Section "Monitor"
	Identifier	"DefaultMonitor"
	VendorName	"ASUS"	# for convenience (not required)
	ModelName	"PB258"	# for convenience (not required)
	HorizSync	24-83
	VertRefresh	50-76
	Option	"PreferredMode" "1920x1080"
EndSection

# 50-screen.conf
Section "Screen"
	Identifier	"DefaultScreen"
	Device		"DefaultDevice"
	Monitor		"DefaultMonitor"
EndSection

Note that anything from the # to the end of its line constitutes a comment, which is unnecessary to the function of the file. The same applies to files in /etc/X11/xorg.conf.d/.

Hi mrmazda,
Many thanks for your fix. Have revised 50-device.conf so will see how it goes.
Very many thanks.

Question: Is the resolution OK in sddm? If so, your kscreen settings may be corrupted. Remove, whilst not logged in on the KDE desktop, ~/.local/share/kscreen, then login on KDE, and see if that improves things, your display should be re-configured.

Hi mrmazda,
Wrote too soon, now back to VGA after trying to use a diacritical character and now cannot shift it at all.
Grub probe gives me an error and I am stuck with VGA.
Can I force grub to accept the EDID?
No idea where to go next.

Interesting question. Did as you suggested and now have a new ~./local/share/kscreen but the resolution is still VGA.
Although I looked at different question/answer initially I am sure the issue is with EDID being messed up but actual screen hardware device is fine so I want to force the EDID in grub.

Hi and thanks for the replies. Sadly I am losing hours with this problem because my server takes five minutes to boot every time and if I get the starting sequence wrong I am still back with low resolution. The annoying irony is that if I switch to Windoze all is well. If I open screen resolution I see 1920 x 1080 (recommended) every time. Sad that windows works and this does not.
If somebody could help me fix the grub resolution and not use the probe I would be most grateful.

What do you mean by getting starting sequence wrong? Why would it happen?

If I open screen resolution I see 1920 x 1080 (recommended) every time.
What do you mean “if”?

Sad that windows works and this does not.
What does not?

If somebody could help me fix the grub resolution
What’s wrong with grub resolution? Grub can only do BIOS/VESA modes, and gives up control quickly after a Grub menu selection is made. OTOH, using Grub to tell the kernel to use a specific mode, output, refresh and more with video= works for most people. If you want the kernel using 1920x1080@60, specify it by putting ‘video=1920x1080@60’ on the kernel cmdline. If you want 1024x768@60, put ‘video=1024x768@60’ there. The intel in particular drivers try hard to ensure that video= parameters are kept applied.

and not use the probe I would be most grateful.
Why do you think you need probe? What exactly is going wrong, and when, currently?

Power outages should not be anyone’s problem, unless they are typically extended longer than a reasonably selected UPS battery set. If not using a UPS any place where power is not reliable, one should expect trouble. If you are running a server, you need reliable power, thus in all likelihood a UPS should be no less a part of your equipment than keyboard, mouse or display.

EDID is from a display, not the gfxcard or driver, which can utilize information EDID provides. Grub utilizes video BIOS information. AFAICT, Grub does not utilize or interact with EDID information.

Hi and thanks for the detailed reply. Sorry if I didn’t make situation clear.

There are three computers connected to KVM switch, one windoze (for accountancy software) and two IBM servers. All are headless, on UPS and unless power supply is off for over an hour quietly just work.

The KVM switch connects to the local (to servers etc) Remote Extender which connects to the remote Remote Extender which connects to the display, keyboard and mouse in the office and at present, (but this will probably change) the office Remote Extender, display, keyboards and mouse are not on UPS, a heritage from when CRT display was too much for a local UPS. For this reason disruptions in the supply can upset the local system and this is cause of my problems as this sometimes loses the saved EDID info from the monitor.

The manner in which the KVM/Remote Extender work is that the EDID info from the monitor is stored in the office Remote Extender box and this info is retrieved by the servers. To have this all work the machines must be turned on or booted in correct order ie. Display>Office Remote Extender>Local Remote Extender>KVM Switch>Computer.

When a server is booted it picks up the EDID info from the grub process and if this is not the actual required monitor EDID info but a spurious default VGA because the starting sequence fails to get the correct EDID info to the booting machine things go pear shaped.

In short I shall now try putting resolution on kernel cmdline.

I’m curious if, when you connect the monitor directly (not through KVM), you still have the resolution problem. If so it would seem like a bug in the KVM kernel driver (if any), as it works in Windows.

OTOH, problems after a power failure are usually indicative of filesystem corruption or, more probable, hardware problem.