How do I downgrade a package?

I recently upgrade to qt4.4.0 and now Skype doesn’t work. I need to go back to qt4.3. Can I do that using YaST?

I run 10,3 x86_64, gnome.

I have read once or twice about being able to right-click somewhere to see available versions, but that has never worked for me. At some point I think I concluded that only worked in KDE.

Help appreciated!

in yast search for ‘libqt4’, then there is a ‘version’ tab here you can choose older version

Not sure about openSUSE 10.3, but in openSUSE 11.0 and libqt4 4.4.0 the openSUSE10+ rpm from skype’s website works great here - also in gnome. Maybe you could also consider reinstalling skype?!

Well, that is interesting. Which build of libqt4.4.0 are you using? I assume that it is the libqt4.4.0-32bit rpm that matters (but maybe not). I’ve seen two versions

I don’t have a versions tab.

Im running 10.3 with yast2 2.15.58-12 (german version)

Gnome by default doesn’t have it manually you can change the yast widget to qt as so…

Open the /etc/sysconfig/yast2 file as root.

Change WANTED_GUI=“auto” to WANTED_GUI=“qt”

You can also do this with the yast tool and sysconfig editor, but details escape at the mo try searching the term yast or auto.

sorry, didnt see its about gnome

Wow! This is incredibly useful. I always vaguely knew that there were two yasts, and I had the wrong one, but this is the fist time I’ve seen the way to fix it. Someone should pin this. Thanks!

I’ve now downgrade Qt4. I think this is resolved.

Well I’m using the 32bit build of libqt4 - I’m running a 32-bit CPU. Be sure to read Skype HOWTO - openSUSE
This sentence seems to be particularly important for you “If you are running on a 64-bit platform, you will also need the *-32bit RPM packages, since Skype is a 32-bit application” - hopefully this will solve your problem.

Thanks. I’ve actually been successfully running Skype for some time, and it broke when I upgraded the qt packages. I know about the 32-bit versus 64 bit, and I had originally had to pull working 32-bit qt4.3 packages off of factory because at the time there were none for available in the normal repositories.

Anyway, I’m back to running qt4.3, and Skype actually works better that it did before with the old factory packages, so I guess that’s something. It still has a few glitches, but I can wait for working qt4.4 packages.

Thanks for your help.