How do I disable tapping function in the touchpad?

Heya,

I’m starting to use KDE4 on my laptop. The ability to tap the touchpad to emulate mouse buttons is driving me nuts !! I checked out the settings in yast, but I couldn’t see any options there that would let me disable this. The touchpad did show up as a pointer device, but there was no ‘advanced settings’ or similar to let fidget with this.

Daqar

Install the RPM gsynaptics. From the command line run the command:

gsynaptics

. From there the answer is clear.

Thankfully to this thread I’ve discovered “synaptiks” - a touchpad configuration for KDE! - don’t know why it’s not installed by default with KDE, but it’s exactly what I’ve missed since migration from KDE3 :slight_smile:

First, I don’t need anymore to keep “syndaemon” running to disable touchpad while I’m typing!

Second - touchpad is working now better than never, and even two-fingers scrolling is working now!

Recommending to all KDE lovers :slight_smile:

Rgds,
-Dimitri

Thanks !! That helped a lot !! :):):slight_smile:

Daqar

Dammit…the solution is not permanent. Everytime I restart the computer or just start it I have to run that command and disable tapping. Is there a way to disable more permanantly?

Daqar

Try running after you log in – this command:

gsynaptics-init

If that restores it then arrange for the command to auto run in your name on login.
Failing that, maybe you’d have to go down a level, to the backend application (synclient) and look at the cofig process for that.

I’m not sure I what I was supposed to do…I tried to put in that command in the terminal after I booted up. Nothing happened. I then ran ‘gsynaptics’ and disabled the tapping from there. I still need to run gsynaptics everytime I start up the computer.

Daqar

We’ve moved beyond my knowledge base I’m afraid.

OK, how about I try synaptiks? How do I download and install that? I can’t find it in the repos I have enabled.

Daqar

It’s available here: Welcome to synaptiks! — synaptiks v0.3

Since you’re using kde, try kcm_touchpad. Find it at Software.openSUSE.org and just select your distro. One-click install should work. It puts a touchpad selection in the keyboard configuration in settings.

My problem is opposite to this topic.
After reboot tapping is disabled.I like better to disable it when not needed.
I use wireless mouse,and adapter is always in usb.Even if it is removed,after reboot - tapping disables.It also disables it self after plugging in mouse adapter .
Funny thing is that touchpad is not recognized in install proces,and on 11.1 was working perfectly.(with wireless mouse adapter always in)
I tried to add gsynaptics-init to sartup applications,but seems to work only short time after reboot.
I use gnome,but will install kde if kcm_touchpad can manage touchpad under gnome.
Can this be solved?
There are things that worked in 11.1 and just no work in 11.2 (like bluetooth that does not remember on/off state after reboot).
I am afraid of future…

I tried following that synaptiks install guide. But I can’t make it work. Heree is the output from the terminal:

jacob@linux-h7fo:~/Install/synaptiks-0.3.2> cdbuild
If 'cdbuild' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf cdbuild
jacob@linux-h7fo:~/Install/synaptiks-0.3.2> cd build
jacob@linux-h7fo:~/Install/synaptiks-0.3.2/build> cmake -DCMAKE_INSTALL_PREFIX=$(kde4-config --prefix) ..
If 'cmake' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf cmake
jacob@linux-h7fo:~/Install/synaptiks-0.3.2/build> make
If 'make' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf make
jacob@linux-h7fo:~/Install/synaptiks-0.3.2/build> sudo make install
root's password:
sudo: make: command not found
jacob@linux-h7fo:~/Install/synaptiks-0.3.2/build>

I dunno what I’m doing wrong here…

Daqar

Maybe first enter “su” to become root then issue the commands. This page describes them (I think): Build and installation instructions — synaptiks v0.3

I tried using th SU command first, and then did the following:

jacob@linux-h7fo:~/Install/synaptiks-0.3.2/build> su
Password:                                           
linux-h7fo:/home/jacob/Install/synaptiks-0.3.2/build # cmake -DCMAKE_INSTALL_PREFIX=$(kde4-config --prefix) ..
If 'cmake' is not a typo you can use command-not-found to lookup the package that contains it, like this:     
    cnf cmake                                                                                                 
linux-h7fo:/home/jacob/Install/synaptiks-0.3.2/build # cnf cmake                                              
                                                                                                              
The program 'cmake' can be found in the following package:                                                    
  * cmake  path: /usr/bin/cmake, repository: zypp (repo-oss) ]                                               

Try installing with:
    zypper install cmake

linux-h7fo:/home/jacob/Install/synaptiks-0.3.2/build # zypper install cmake
Loading repository data...                                                 
Reading installed packages...                                              
Resolving package dependencies...                                          

The following NEW packages are going to be installed:
  cmake make                                         

2 new packages to install.
Overall download size: 5.6 MiB. After the operation, additional 19.0 MiB will be used.
Continue? [y/n/?] (y): y                                                              
Retrieving package make-3.81-130.2.x86_64 (1/2), 356.0 KiB (981.0 KiB unpacked)       
Retrieving: make-3.81-130.2.x86_64.rpm [done (269.8 KiB/s)]                           
Installing: make-3.81-130.2 [done]                                                    
Retrieving package cmake-2.6.4-3.3.x86_64 (2/2), 5.2 MiB (18.0 MiB unpacked)          
Retrieving: cmake-2.6.4-3.3.x86_64.rpm [done (26.9 MiB/s)]
Installing: cmake-2.6.4-3.3 [done]
linux-h7fo:/home/jacob/Install/synaptiks-0.3.2/build # cmake -DCMAKE_INSTALL_PREFIX=$(kde4-config --prefix) ..
-- The C compiler identification is unknown
-- The CXX compiler identification is unknown
CMake Error: your C compiler: "CMAKE_C_COMPILER-NOTFOUND" was not found.   Please set CMAKE_C_COMPILER to a valid compiler path or name.
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
CMake Error at /usr/share/cmake/Modules/FindKDE4.cmake:84 (MESSAGE):
  ERROR: cmake/modules/FindKDE4Internal.cmake not found in
  /root/.kde4/share/apps;/usr/share/kde4/apps;/etc/kde4/share/apps
Call Stack (most recent call first):
  CMakeLists.txt:6 (find_package)


-- Configuring incomplete, errors occurred!
linux-h7fo:/home/jacob/Install/synaptiks-0.3.2/build #

I dunno if I’m heading the right direction here…

Daqar

No need to install any additional packages. You can set up everything as part of X policy files.

Look at my response to another thread here:

Synaptics Multi-Touch - openSUSE Forums

Thanks !! That worked !! :):):slight_smile:

Daqar