how do i disable nouveau in opensuse 13.2?

hi all i just want to know how do i disable nouveau in opensuse 13.2
thanks , nid

echo "blacklist nouveau" > /etc/modprobe.d/50-blacklist-nouveau.conf 

, then reboot.

i try it after i install opensue 13.2 but its not working. when i try to install nvidia drivers its still tell me that i need to disable it.

Try:


# mkinitrd

so that the blacklist information gets into the initrd.

And how do you install the nvidia drivers?
Where does it say you need to disable nouveau?

If you install the packages from the repo, you won’t have to do anything manually.
https://en.opensuse.org/SDB:NVIDIA_drivers

don’t use the bin driver from nvidia as every time there is a kernel update you might have to re-build and re-install the driver, in yast add the nvidia repo and yast will select the appropriate nvidia driver for you (there are 3 of them) plus the software updater will update the driver for you too.

You can prevent it from loading at boot when already installed by the nvidia proprietary driver by adding nomodeset in your kernel parameters.
You can do it in yast bootloader.

Or you can blacklist it in /etc/modprobe.d/50-blacklist.conf
by adding this entry

blacklist nouveau
options nouveau modeset=0

I use the later

On a side note.
When you run the nvidia installer it attempts to blacklist nouveau and write a config
in /etc/modprobe.d, in previous version of openSUSE it works for me but in 13.2 it doesn’t.
Try looking in the /etc/modprobe.d for a file named, nvidia-installer-disable-nouveau.conf
if it is there copy and paste the content in /etc/modprobe.d/50-blacklist.conf.

The content for sure will be the same as the one I posted in the code.

You may need to run mkinitrd after adding the above and then reboot.

Indeed that was the case for me, where I not only needed to apply the entries to the 50-blacklist.conf that you noted, but also needed to run ‘mkinitrd’ which you also noted . The graphics on my 64-bit PC (with 64-bit openSUSE-13.2) is a relatively old GTX-260 and I am using the proprietary nVidia driver 340-58 (installed the manual method). I’ve been using the manual method to install the proprietary driver for years, I am not bothered by the occasional kernel update breakage of the graphic driver build, and I guess old habits die hard for some of us (such as for me).

Also for me, this is simply the latest wrinkle that is easy to address, once one knows how.

Thanks for your post with the information.
.