How do I disable a module during installation


 How do I disable a module during installation from the "boot options" prompt in the installer menu?  My Via SATA raid is causing problems during installation and I want to disable the module "sata_via" prior to installation at the "boot options" prompt.  I am thinking that there has to be a kernel argument to do this.  Any help is appreciated.

just put “badmodules = name_of_module” without the quotes & you should be good to go


Thank you for your answer. I really apreciate your expert advice and I did not even know the badmodules argument existed. I tried the badmodules argument and could not get it to work. In openSUSE 10.3 all I had to do was disconnect the RAID drives during install and then re-connect them after the install was complete. In 11.0 I got a bad pb signal or something like that after connecting the RAID drives and openSUSE would not boot. I have also let the openSUSE installer attempt to write to the MBR of the RAID (with the RAID drives connected and configured properly during openSUSE install)and that did not work either. Love the new version on my laptop and I am determined to get it working on the desktop as well. I even tried deleting the BIOS RAID config and disabling everything RAID related in the BIOS and could not get version 11.0 to cooperate.

I found out that the command used during installation is brokenmodules=module_name. There was a comment in the text displayed when the installer boots up. I also noticed that this argument was automatically changed to badmodules=module_name when I checked settings after installation. Just like deltaflyer44 said. Works perfect now.

Excellent, glad you got it working.Now enjoy :slight_smile: