How do I debug a program in Kdbg 2.5.1 on openSUSE 12.2(X86_64)?


I want to debug a program using Kdbg. When I open an executable Kdbg displays a warning dialog with the title “Sorry”. The text is:
GDB: Reading symbols from <path to my executable> …done.
No hint why it is sorry about that. Afterwards, I cannot do anything useful (run, step into, step over,…), as all the buttons and menu items for these actions are grayed out. If I invoke gdb directly, it displays the same message (Reading symbols ]… done). I can run my program using gdb.
I use the default settings of Kdbg.

Any hints appreciated.

Thanks, Stephan

On 12/23/2012 05:06 PM, stephanhh wrote:
> I want to debug a program using Kdbg.

i think you are trying to run a KDE3 program, in KDE4…theoretically
it should work, but…good luck!

i see very few questions in our forums, way back…see:

i did find a post where one person said upgrading to Kdbg to 7-something
solved the problem…

you might find more help in a forum specialized on Kdbg, try:



Kdbg 2.5.1 uses KDE platform 4.8.5. I don’t think it’s for KDE3.
I installed some additional debug libraries (from the debug repository). Now the ddd debugger works fine. The behavior of Kdbg is still the same, though.

Thanks, Stephan