How do I connect to Wifi? I can't see any networks

I have two wireless devices, a built in Broadcom, and an external Alfa Network (uses Realtek). Both used to work out-of-the-box in Ubuntu (though the Broadcom required a system update before it started working).

In Suse, I click the Globe on the bottom right, and at the top I see eth0 and wlan0 which are my two wireless devices. I click but nothing happens.

Also in the globe, I see “New connection”. Mousing over it again displays eth0 and wlan0. I click wlan0 and I see a “connections” box which looks like it should contain a list of networks but is empty.

Thank you.

I’m going to proceed to finding and installing some drivers. My confusion was that I can see the devices eth1 and wlan0 so I thought that they might already be working.

with the broadcom device, you may be able to use the b43 driver/firmware. If you have a look through the stickies at the start of this section,you will find info on getting the driver/firmware. if you get stuck, post back & we will see what we can do



You’ve maybe enabled the option not to display the SSID of your wifi. I’ve got the same problem.

If you know all important settings, just do

New connection->here choose the desired device(my case eth0)
→ then fill out the field ESSID(name of your WiFi)
→ now choose your encryption method(WPA/WEP) and enter the key
→ enter your ip just if your WiFi uses static IPs,otherwise proceed to last step
→ Choose a name for the connection, maybe “WiFi” or kinda…
select auto connect or don’t and at last click on “connect and save”

Thats it.
Now you should have a working WiFi.


I connected using LAN, did a system update and it started working. I think that the same had happened in Ubuntu also.

Turns out that eth0 is my ethernet, so my internal wireless is not appearing. Going to attack that now.