How do I configure multiple NVIDIA monitors?

As both root and myself, I’ve gone into the:
configure desktop -> display and monitor
thing and set “primary output” to “DVI-I-1” and
set the DVI-I-2 connection to the “Right of DVI-I-1” position
and then clicked “apply”
and then clicked “yes I want to apply”
and then clicked “save as default”
and then clicked “Yes I want to save as default”
and then clicked “I understand you have changed the default”
and then logged out and back in. Back to a cloned monitor.
Doesn’t work when done either as root or as me.

So, there must be a way. How?

I have an hdmi and dvi hopefully this will work for you.
If you want to make primary the one from the other you have to disable first the present primary as su in the nvidia-settings, then physically turn it off. The monitor that you want to be the primary should be configure to the position as absolute in the xscreen configuration. Save it and reboot your computer maintaining your present primary monitor to be physically off. When you login and start the nvidia-settings the second monitor will aquire the first position then you can turn on the other monitor and do your desired configuration. Of course you have to do this in the nvidia-settings as su.

Good luck

Hi. I’m not understanding. I don’t really care which one is primary. I can always
make the other one be to the left of or the right of the primary. As it happens,
the chosen primary is the left one, so I make the secondary to the right of the
primary. THE problem is that after making it to the right of the primary, the
next time I log in, it is a CLONE of the primary. Who wants a clone anyway?
How completely useless! (Unless you’re doing a demo from a lap top, but the
software ought to know it isn’t a lap top, so who wants a clone anyway?)

PS. I missed a click step. Here’s the correct sequence:

  1. click apply
  2. click confirm apply
  3. click save as default
  4. click an ALTERNATE save as default
  5. click “yes I really want to”
  6. click “I realize you’ve set the default”

SIX clicks to make the setting I’ve gone to all this trouble to do. sigh.

Ok, I got what you mean
Configure it as a separate screen you must have configured it as twin view.
I have a working two monitors with separate screens meaning it has it’s own different monitor settings in 11.4
And it requires a reboot not just logout and login.
If this one will not work, it’s probably missed-up.
Good luck

I’ve rebooted many times now. I have no idea how to tell 11.4 that I want separate screens.

Sorry can’t help you more.:frowning:
The only thing I can think of is if you are using kde it’s set to remember your last session.
Try to configure it not to, If you are using kde and this is just a guess. :\

[QUOTE=conram;2303885]Sorry can’t help you more.:(]/QUOTE]
Thank you so much for trying…

… if you are using kde it’s set to remember your last session.
Try to configure it not to, If you are using kde …

Um, yes, I’m using KDE. I surely do hope that KDE is not that lame.
Resetting the monitor configuration to a broken state at the start of each
session is just too utterly ridiculous to believe it possible. Nobody would do that…I hope :frowning:


I totally believe youlol!
Leaves me scratching my head why I posted it.
maybe because I’m ignorant with kde, i am using xfce.

In the past I have had to:
Log into X as root.
Use nvidia-settings to configure and merge new settings into xorg.conf

I have never had much luck using the build in KDE with the proprietary NVIDIA driver.

Hi and welcome to the Forum :slight_smile:
It’s better to use gnomesu or kdesu as your user eg;

kdesu nvidia-settings

Save yourself a ton of headaches.

Update to a recent (260.16 and later?) driver from the nVidia repository (either configure as a YAST/Zypper repository or d/l direct from nVidia).

This should automatically install the nVidia Configuration Manager tool which will address all multi-monitor configs plus a lot more (manually tuning, temp, more).