How do I change sort order in file dialogs?

On my TW/KDE system when I open a file dialog in an application all the file dialogs display the files and directories in name order and do not group the directories first, I’d like to change this so that all file dialogs display the directories first followed by the file, each in name order but so far I’ve not found any way to achieve this.

How can it be done please?


As far as i know there is no unique answer to your question.

On my system most KDE applications (e.g. KMyMoney) use the standard KDE file open dialog which shows a button on the top that will allow you to customize the sort order.

Firefox (which is not a KDE application) uses as different file open dialog (i don’t know how to configure the sort order there) and LibreOffice allows you to choose between the LibreOffice and the standard KDE file open dialog.

Probably there are other applications which bring their own file open dialogs or use file open dialogs from other DEs.

So probably it’s best you specify which applications file open dialog you want to customize.



Thinking about it I believe Firefox/Waterfox and Thunderbird are the main culprits and obviously use their own dialog, that’s a PITA because I think not allowing fully customisation or switching to KDE dialog is plain wrong. Most others I’ve tried so afr seem to follow the KDE standard which is what I expect to have.


These apps are built with GTK tools.

Most others I’ve tried so afr seem to follow the KDE standard which is what I expect to have.
KDE is built using QT tools.

GTK and QT are quite different. IMO QT users are lucky GTK apps work at all in KDE, which I expect would not have happened at all but for the existence of Mozilla products 2+ decades ago.

Have you “kmozillahelper” installed? - That provides integration of FF & TB with KDE file dialogues…

Yes it is installed but not sure what to expect to see or whether anything needs adding as a plugin or extension.


It (mostly) “just works”, no plugins or extensions…

When “kmozillahelper” is installed Firefox and Thunderbird will use the KDE (rather than native gtk) dialogues for file open/save.

Unfortunately the print to file dialogue is still native gtk, see bug

Reading between the lines it would appear that the Firefox code is patched for openSUSE but I dont normally use Firefox I use a clone Waterfox so I doubt that kmozhelper will do anything for that. Pity Mozilla dont use QT or supply a version which does, or use normal KDE file menus.


I can confirm this.

Although the file selection dialog for printing in to PDF-files looks different it still allows to configure the sort order (by using the right mouse button in the file list panel).

My system:

Operating System: openSUSE Tumbleweed 20210307
KDE Plasma Version: 5.21.1
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2
Kernel Version: 5.11.2-1-default

# zypper se -si firefox kmozilla
Loading repository data...
Reading installed packages...

S  | Name                               | Type    | Version   | Arch   | Repository
i+ | MozillaFirefox                     | package | 86.0-1.1  | x86_64 | openSUSE-Tumbleweed-Oss
i  | MozillaFirefox-branding-openSUSE   | package | 68-2.3    | x86_64 | openSUSE-Tumbleweed-Oss
i  | MozillaFirefox-translations-common | package | 86.0-1.1  | x86_64 | openSUSE-Tumbleweed-Oss
i+ | kmozillahelper                     | package | 5.0.6-1.3 | x86_64 | openSUSE-Tumbleweed-Oss



I can confirm that Firefox works as expected with the normal KDE open file dialog. The issue is that it does not work with Firefox clones like Waterfox and I suspect this cannot easily be fixed. This also explains why my Thunderbird does not use the KDE dialog because I use an older version installed manually not the system version as that does not support extensions I will not work without.


Have you looked at this, perhaps it would serve your (waterfox) needs…

According to that site the Tumbleweed build failed! I already use it on my wife’s 15.2 laptop. I’ll keep an eye on it in case something changes.


Ah! So it is… Sorry, didn’t scroll down the page so I missed that :embarrassed: