How do I cause SuSE 12.2 to use only the wireless interface for Internet access?

I have a freshly installed 12.2 system:). I have both a wired and wireless network interfaces. Both interfaces work well, except the system is wanting to access the Internet with the wired interface only resulting in my having to turn it off so I can access the web. How do I cause the system to “favor” the wireless interface for Internet access. In the network settings I have set the wireless as an external zone and the wired as an internal zone, but no affect:sarcastic:.

Any assistance will be greatly appreciated.
Walt Williams

It may be interesting to help us understand why you would prefer wireless
to wired, especially when both apparently get to the Internet. Typically
a wired connection will be the better one because it’s not wireless.

Still, if you want to, you need to convince your system’s default gateway
to be the one available via wireless. This, in my mind, presumes that
your two network connections (wired and wireless) are on different
networks. If that is the case, set the default route’s gateway to be the
gateway of the wireless connection. The wired connection’s gateway will
not be used until you change things. If you control the wired connection
and can convince the DHCP server for it to NOT provide a default gateway
that may also do the trick, but then it’ll never give you a gateway even
when you want it so you would need to set that manually if ever desired.

If both interfaces actually connect to the same network (for example,
while at home), then you’ll probably need to explicitly state that the
default route is the one on a particular (wireless) device, and I’m not
sure you can do that via Yast, so you’ll probably need to use the ‘ip’
command to manage it. Before doing that, I would still wonder why this
was the desired implementation. If both connections go to the same
network why prefer the wireless one, and if accessing the Internet, why go
through the wireless connection to the gateway if both devices can reach
the same network? It would be far simpler, and in fact faster all around,
to just have the wired connection when possible and use the wireless
connection when the wire isn’t close, at least when both go to the same

Good luck.

Pull the ethernet cable.

I like it. Oh so Simple. Who would have thought?

Thank You for using openSUSE,

On 01/05/2013 11:46 AM, jdmcdaniel3 wrote:
> hcvv;2515814 Wrote:
>> Pull the ethernet cable.
> I like it. Oh so Simple. Who would have thought?

If you want to leave the wire plugged in, then in the NM applet, click on the
red X for the wired connection. That will shutdown the wired interface.

Correct me if i ma wrong.I thought internal and external zone settings are meant to be profiles for firewall and not controlling working of connection.

system is wanting to access the Internet with the wired interface only resulting in my having to turn it off so I can access the web

Have we tried disabling the relevant hardware through YaST==>Network Settings

Of course! And when both connect to the same LAN, this firewall construct is hilarious.

In fact we are missing a lot of information

. Background. Are both connections realy going to the same LAN? Why then connecting a cable when the Wifi is preferred (for whatever reason)?

. Facts. Is this configured using ifup or NM? And how? Is DHCP used?

. Backed by computer info: contents of /etc/sysconfig/network/ifcfg-*, /etc/sysconfig/network/routes, output of netstat -rn.

I always wonder how people can give all sorts of advice without knowing all these facts :question: That is why I offered my cable solution. Assuming more or less nothing rotfl!

If you always use the computer in the same location, then I recommend using “ifup” network settings, instead of NetworkManager. You can set that in Yast network settings.

While in Yast network settings, there is a tab for “routing”. You can use that to set the default gateway, and specify if for only your wireless interface.

Okay, I have a cold so its no wonder I forgot to include a detail or two.

The wired has no access to the Internet, but the system seems to want to favor it (For good reason-Its faster). The wired is being used to connect my printer through a LAN print server. The wireless is the network that belongs to my brother that has access to the network/Internet .

That is only answering half of the questions asked. And no computer facts at all. the above explains why you don not like pulling the cable. But I hope those are realy two LANs with two different address ranges. Thus I repeat, post

cat /etc/sysconfig/network/ifcfg-*
cat  /etc/sysconfig/network/routes
netstat -rn

and answers on:
. configured using ifup or NetworkManager?
. using DHCP?

I am thinking you need to setup some sort of routing between these two network interfaces. As a normal course of action, openSUSE is going to use only one network interface. Either manually selected (As in manually using ifup), or in the case of Network Manager, it prefers a wired network connection over wireless if they both should exist at the same time. Routing allows information on one network interface to be sent back and forth to a second or third network interface. I have not setup network routing before in openSUSE, but a search on the subject does turn up a few message on the subject in this forum. I suggest a new message thread asking help to setup a route between these two network connections on the same PC.

Thank You,