How do I automount a cdrom?

Opensuse 11.2, KDE 4.3.5
I have read many articles on this forum & on the web but I am still not able to automount a data CD (I haven’t tried audio yet).

I created a directory /media/cdrom
I added my user name to group disk & cdrom.
I added the following line to fstab (my drive is an ide cdwriter):
/dev/sr0 /media/cdrom auto auto,user,rw 0 0

If I put a cd in the drive there is lots of action of the read light but nowhere within KDE that I can find to access the CD. Is it possible that making a change to ‘device actions’ in ‘configure desktop’ is what I need to do? If so, what do I enter or change?

From terminal the command ‘mount’ does not show it mounted. At this point I can manually mount the cd.

Also note that in YaST it shows up in the hardware list after probing hardware but it does not appear anywhere else in YaST (and I don’t know if it is supposed to show up).

jon@linux-0rrf:~> sudo lshal -m

Start monitoring devicelist:

15:50:35.474: storage_model_CD_RW__CRX195E1 property storage.removable.media_available = true
15:50:35.513: storage_model_CD_RW__CRX195E1 property storage.removable.media_size = 725323776 (0x2b3b9000)
15:50:35.517: storage_model_CD_RW__CRX195E1 property storage.cdrom.write_speeds = {‘7040’, ‘5632’, ‘4224’, ‘3520’, ‘2816’, ‘2112’, ‘1760’, ‘1408’, ‘704’, ‘352’}

So the system seems to know I put a cd in the tray but it doesn’t mount automatically. Is my fstab entry correct?

I’d like to find it in Dolphin or in the menu for ‘Computer’ under Removable Storage, just as the floppy drive and a usbstick shows.

How do I fix my problem?

Thanks, jon

When I place a program disk in my CD-ROM drive my KDE device notifier plasmoid (which you can add), gives me an option to view the CD using Dolphin. Further, if I open up the My Computer icon, I see the disk label and size listed. You can see the My Computer function if lost by starting Konqueror in Web Browser mode and going to the URL “sysinfo:/”.

When a CD is automounted for you, it is mounted in

/media/Disk Label

And there is no need to create any folders for this action to occur for you automatically.

Thank You,

James:

Thank you for the reply, however your suggestions do not work for me.
I have the notifier in my system tray and all the possible notification boxes are checked. Nothing happens when I place a CD in my tray other than I see the read light active on the cd device.

Konqueror sysinfo works correctly, it is in my desktop folder as “My Computer” and also accessable from the menu. It does not show the CD, whether I manually mount it or merely insert it in the tray. Whereas if I insert a usb stick it works correctly and exactly as you describe. Also, sysinfo shows an icon for a floppy in the same location I would also expect to see an icon for a CD.

Furthermore, I just tried a floppy and other than it showing an icon in sysinfo, it too doesn’t work, just like the CD doesn’t work. Nor can I mount it manually because I have not created a mount point in fstab. The result is exactly the same as I got prior to creating a mount point in fstab for cdrom.

mount /dev/fd0

mount: can’t find /dev/fd0 in /etc/fstab or /etc/mtab

So I’m back to my original question. How do I fix my problem of the CD not automounting? I presume whatever answer I get on this will also work for getting my floppy automounted.

Thanks, jon

6520302 wrote:
> So I’m back to my original question. How do I fix my problem of the CD
> not automounting? I presume whatever answer I get on this will also
> work for getting my floppy automounted.

a successful install of Opensuse 11.2, KDE 4.3.5 will be born
automatically working this way:

-complete install and YaST applied updates
-do nothing else to your system
-insert a CD or DVD
-wait a second or two and HAL will cause a popup to appear on your
desktop offering a variety of things for you to select from (depending
on if it is a DVD or CD and what is on it) play audio, burn new disk,
watch movie, open in konqueror, or etc etc etc…

if that is NOT working automatically then either your install went
bad, or you tried to use some OLD how-to to mount and killed your
automatic system…

like: adding a line about the CD/DVD drive in fstab KILLS the
automatic process…take it out!

if that doesn’t get the automatic process working then: try booting
from you install media and selecting “Repair Installed System” AFTER
doing this: http://tinyurl.com/yajm2aq which, if it throws ANY errors
you should throw that disk away and begin aging here:

http://en.opensuse.org/Download_Help
http://tinyurl.com/yhf65pv
http://tinyurl.com/ycly3eg

and, while moving forward in learning openSUSE be very careful in
selecting how-tos and step-by-steps off the web to follow…because if
you happen on one from (say) 2005 (or 1995) written for (say) Debian
(or S.u.S.E.) you are likely to do more harm than good…try, for now
to stick to openSUSE 11.2 instructions…to get started on that see my
previous post here: http://tinyurl.com/ybklh48


DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
posted via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
2.6.22.19-0.4-default SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

Le 26/04/2010 07:06, 6520302 a écrit :

> So I’m back to my original question. How do I fix my problem of the CD
> not automounting? I presume whatever answer I get on this will also
> work for getting my floppy automounted.

first, to guess what happen, try creating a news user, login as this
user and insert a cd.

On the fully new kde install, the CD should show. If it show in the
new user, you have something wrong in your owb config, else it’s more
deep problem.

jdd

use of the mount command has 3 parts mount [options] [device] [mountpoint]
options can be eliminated if not required for the device.

If an entry exists in fstab or mtab for the device then mount can’t work unless you manually umount the device.

With CD/DVD drives automount creates a mount point under /media as /media/cdrom0. Inserting a CD into the drive will pop out new device notify where you can right click the device (assuming you have priviledges for it) and choose the action you want to do. You may also open dolphin and see it listed along the left side of the screen.

That should be:
#mount /dev/fd0 /media/FOLDER_YOU_WANT_IT_TO_MOUNT_IN
Mind: the folder has to exist. If not create it first, with permissions 775, group users.

DenverD

Thanks for the info. I took the line I added out of fstab and this is what it looks like (ie: presumably as created by the install).
/dev/disk/by-id/ata-ST340014A_5JXF0RK0-part5 swap swap defaults 0 0
/dev/disk/by-id/ata-ST340014A_5JXF0RK0-part6 / ext4 acl,user_xattr 1 1
/dev/disk/by-id/ata-ST340014A_5JXF0RK0-part7 /home ext4 acl,user_xattr 1 2
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

When I put a CD in the tray I’m back to where I was. The files are nowhere to be found (this time I used my v11.2 install disk). No app was started and no notification from KDE was received. The disk reads but there is nothing in /media. So I’ll try the repair system.

My install of v11.2 was done by installing over v9.x and formatting the disk so what I have should be clean. I did a media check prior to installing.

Thanks,
jon

DenverD:

I am booted to the liveCD. I have just successfully run the ‘check installation media’ and it shows the correct md5.

There is NO selection on my Suse Installer menu for many of the choices on the referenced link. There is no choice for either Repair or Rescue.

Since the md5 is correct I am wondering why my install CD does not have those choices. It pretty much forces me to reinstall and to re-download the YaST updates all over again. I was hoping to avoid that.

Is there something I can put into the boot options to accomplish a “Repair Installed System”?

Jon

To get the “repair install” option, boot off of the cd, go to installation, follw the prompts, and read carefully, it will show up in the beginning…

-cheers

Le 26/04/2010 20:06, subcook69420 a écrit :
>
> To get the “repair install” option, boot off of the cd, go to
> installation, follw the prompts, and read carefully, it will show up
> in the beginning…
>
> -cheers
>
>
or use the dvd. Live cd is just a demo way

jdd

I tried that, up to the creation of a user ID. I didn’t see a choice to ‘repair installation’.

Again, this is live CD, not DVD.

jon

Unfortunately, my 6 yr old computer doesn’t have a DVD. I’ll give the install that subcook mentioned in case I overlooked the option to repair.

Jon

I have a CD-ROM drive and a DVD-ROM drive. The DVD-ROM shows in Dolphin’s Places panel but as “CDROM”; the CD-ROM does not show at all and putting a disk into it has no effect whatsoever.

Additionally, mount is unable to auto recognize a data CD so I have do put iso9660 explicitly into the fstab.

Sorry for bringing up old problem! I am using Tumbleweed on iMac. DVD discs works OK.

I am able to mount data CD-ROM manually with command:

*# mount -t iso9660 /dev/sr0 /mnt
*
After that I am able to access it with Dolphin. So, my CD-ROM physical device is OK. But there is something wrong with Default Applications Manager. I was not able to find how to configure it and add new action for data CD.

lsblk -f gives:

NAME FSTYPE LABEL UUID MOUNTPOINT
sda
├─sda1 vfat ACF0-7C64 /boot/efi
├─sda2
├─sda3 btrfs 2b15ede9-bcd3-4d04-acfb-6ebf3ec8eb32 /boot/grub2/x86_64-efi
├─sda4 xfs 8d893ca1-5415-48dd-aecb-79abd022306d /home
└─sda5 swap ce7c9556-e467-4d1f-8b82-a7d115ea1b6d [SWAP]
sr0 iso9660 My Disc 2004-11-14-14-47-00-00

Hi, welcome here,

Please start a new thread, this one is too old.