How Do I Access Remote Media?

I finally got Amarok and other media players working with the local mp3 files. However, I keep my files on a server. This setup works fine for Windows so it hasn’t been a problem until now. The server is Ubuntu and I share the files using SAMBA. I know (very little) about NFS but I need SAMBA for the Windows clients so there is no NFS setup.

I can see the SAMBA shares in Konqueror but I cannot open SAMBA shares with Amarok, XMMS, or anything else. I think I need to mount the SAMBA shares on OpenSUSE (11.2) to access them with Amarok, etc. I would then include these shares in the fstab file on my OpenSUSE box to include them at boot. Is this correct? I’m pretty much looking to confirm my suspicions here. Thanks.

Mark

Try mounting the remote ubu share with a cifs mount as describes here: Samba: HowTo Mount a CIFS Network Share [AKA Map Network Drive] in openSUSE 11 plus FAQs

I’ve been trying to get Amarok to work (without killing system sounds) for weeks!
Check Multimedia Problems in 10 Steps
Welcome to Multimedia Sub-Area
SDB:AudioTroubleshooting - openSUSE
PulseAudio - Perfect Setup
And other references have helped greatly but always ended exchanging one for the other. How did you do it?

@swerdna
Thanks. I’ll check that link out.

@KohlinGA
The answer is that you hope to God that swerdna sees your post and has an answer. Just kidding. But seriously, swerdna is quick and helpful and you can get great help on these forums if you are specific enough about your problem. Rare for a Linux forum, trust me.

I got help a couple of weeks ago with Amarok from swerdna and others. My experience was that there were also issues with hardware that I needed to investigate. Short of having someone come to my house, I didn’t want to bore the forum with my hardware details. This is not to say you should hesitate as it seems some people are infinitely helpful.

I’m not a Linux noob (nor a Linux expert), just an OpenSUSE noob. I had hoped to resolve this by command line but ultimately I had to put away command line aspirations and just use the one-click option to get it working. Somehow, this worked. This “packman” package is critical and the instructions are straightforward but my computer is about 8-9 years old so it was still tricky. I used the following links. Sorry I couldn’t be more helpful. Good luck!

Mp3 Guide

Multi-media and Restricted Format Installation Guide - openSUSE Forums

Restricted Formats/11.2 - openSUSE-Community

Amarok Audio Output - openSUSE Forums

This is the one-click option, which I think worked for me.

openSUSE 11.2 | SUSE Linux | Beginner’s guide to multimedia codecs MP3 DVD 3D nvidia ati wireless

I just follow my own guide.:slight_smile:
Have done 4, 11.2 installs this week. All work perfectly
Multi-media and Restricted Format Installation Guide - openSUSE Forums

@swerdna

The link you recommended worked! I had to make adjustments on the server side as well (https://help.ubuntu.com/community/SettingUpSamba) but it works now. Amarok is still giving me grief but everything is working on XMMS2. Thanks!

Mark

Good to hear…

A most beautiful horse!