How did I disable graphical login?

Hi all,
I have a virtual machine running Tumbleweed.
Some time ago (one year or more) I remember that I wanted to avoid that machine to boot into graphical mode.

However, apparently I did not change the default runlevel, but instead I did something else.

The machine is booting to a text-mode black screen with no login.
I can easily access the machine through SSH, which was the intended behavior, since I only needed remote access to the CLI.

Now I need that machine to boot normally again, but I cannot remember what I changed to make it behave this way.

I have tried looking in various forums/wikis, but I cannot find any suggestion that actually matches what I see on that machine.

So I’m asking for help here: if you have an idea of how I could have done it, could you please share it with me?

Thank you in advance.


was a 5 added to the grub command line?

On 10/17/2016 04:56 AM, keellambert wrote:
> was a 5 added to the grub command line?

You need to set the default mode (runlevel no longer applies) using
systemctrl commands. I’ve never needed to change it but I know that many
on this forum do.

linux since 1994
S.u.S.E./openSUSE since 1996

check whether /etc/systemd/system/ isn’t linked to the

Hi keellambert, kensch and Knurpht,
and thank you for your replies!

No, that’s not the case.
BTW, wouldn’t that leave me with a text-mode login prompt at boot? I do not have a login prompt, I have simply a black screen.

Kensch, I am not asking how to do this. You probably missed that in my original post.

Knurpht, good call! But unfortunately that’s not the case :frowning: (i.e. the link is intact).

Thank you for all your suggestions!

I hope that someone else will come up with other suggestions too!


Check if you have done weird modifications at grub.cfg, the graphic mode could be messed from there too.

Thank you ZeroG.

Unfortunately, nothing weird here.


Then why isn’t the title of this thread and your problem description mirroring this?

You did not reach any usable run level, you are hanging somewhere with a black screen.

Hi hcvv!

Maybe my title was not clear enough, but my description - as you can see - was mirroring this.


-SystemSettings --Display and Monitor allows the Display to be Enabled/Disabled
via a check box

[QUOTE=Cris70;2796481]Hi hcvv!
Maybe my title was not clear enough,

You forgot that your title is the main point to draw the attention of the people that are most likely able to help you.
After reading your title many people will not even open your thread because they feel not entitled to “read minds” and tell you what you did somewhere in the undefined past.

There is another thread (in Chitchat) where several of the more active members here (and they are those that give good advice imho) explain that time contraints make them skip threads with uninteresting (read having subjects they feel they have not enough ot no knowledge) or vague titles.

[QUOTE=Cris70;2796481]but my description - as you can see - was mirroring this.


And what makes you conclude that it is “text mode” and not simply black? Can you type there?

Henk, I perfectly understand this but I fail to see how adding this bit of information in the title (i.e. that the system is not showing a login screen) could possibly make them feel they can read in my mind.
If they chose to skip it, so be it. I can certainly accept it and not be offended by their behavior.

If I could find a better wording to attract people to my thread I would have used it, but you should also remember english is not my first language.
This forum is not configured to let the OP change the title of the thread (I may be wrong, but if there’s a way it is well hidden) so I cannot fix it now.

Because there is a cursor blinking, and that makes me think it is in text mode. I did not try to type.

Henk, I understand you’re the moderator here, but - if I may - let me say you’re getting through quite rudely, and I really fail to see where I’m deserving this.

Anyway, sorry if I’m breaking some kind of rule I failed to learn. Feel free to educate me via PM.


Can you ssh into the machine? Or, add a “1” as a boot parameter in GRUB? The latter would boot the machine in single-user mode, if that works, reboot, try the same with “3” instead of “1”. Hit Esc during boot to see the messages.

maybe you did something to the /etc/X11/xorg.conf file, if it exists renaming it might fix things
or you did something in /etc/X11/xorg.conf.d/
or did something in /etc/X11/xinit
what was your default login manager text mode

Hi Knurpht!

Yes, I can SSH into the machine without problems, and everything is working as expected.

There is nothing - apparently - wrong with that machine, apart from the fact that it does not show the text-mode login during boot.

If I hit ESC during boot I can see that it thinks it has got to the Graphical Interface target, but the screen remain black with a blinking white text cursor in the upper left corner.

There’s no indication of an error in the boot messages. But I wouldn’t be expecting it, because as I said this was a deliberate move… it’s just that I don’t remember how I did it! :slight_smile:

I tried booting into mode ‘1’ and into mode ‘3’ and both worked without problems, giving me the text mode login prompt.


I do not see signs of alteration in those directories, apart from the fact that the xorg.conf file has already been renamed to xorg.conf.install.
Is this normal?

Another thing is that there is a 00-keyboard.conf.backup file, but I do not think that altering the 00-keyboard.conf file could determine the inability to reach the login prompt. Moreover, the two files are identical.

cristiano@VD1SL001:/etc/X11> ll
total 24
drwxr-xr-x 1 root root   12 set 13 09:25 fs
drwxr-xr-x 1 root root   22 set 13 09:26 lbxproxy
drwxr-xr-x 1 root root   16 set 13 09:27 proxymngr
drwxr-xr-x 1 root root  428 set 13 09:28 xdm
-rw-r--r-- 1 root root 7003 giu 15 14:17 xim
drwxr-xr-x 1 root root    8 lug  5 12:14 xim.d
drwxr-xr-x 1 root root   78 ott  2 01:11 xinit
-rw-r--r-- 1 root root 1353 set  2 01:52 Xmodmap
-rw-r--r-- 1 root root 1049 set  2 01:52 Xmodmap.remote
drwxr-xr-x 1 root root  430 ott 18 09:49 xorg.conf.d
-rw-r--r-- 1 root root  874 mag  6  2015 xorg.conf.install
drwxr-xr-x 1 root root   50 set 23 10:12 xorg_pci_ids
-rw-r--r-- 1 root root 4017 apr 22  2009 Xresources
drwxr-xr-x 1 root root   20 set 13 09:27 xsm
cristiano@VD1SL001:/etc/X11> ll xinit/
total 16
-rwxr-xr-x 1 root root 1112 dic  5  2012 xinitrc
-rw-r--r-- 1 root root 5178 giu  1 14:36 xinitrc.common
drwxr-xr-x 1 root root  118 ott  6 09:18 xinitrc.d
-rwxr-xr-x 1 root root 1112 dic  5  2012 xserverrc
cristiano@VD1SL001:/etc/X11> ll xorg.conf.d/
total 56
-rw-r--r-- 1 root root  320 mag  7  2015 00-keyboard.conf
-rw-r--r-- 1 root root  320 mag  6  2015 00-keyboard.conf.backup
-rw-r--r-- 1 root root 1099 ott  6 14:58 10-evdev.conf
-rw-r--r-- 1 root root  488 set 17 20:06 10-libvnc.conf
-rw-r--r-- 1 root root 1350 set  2 15:12 10-quirks.conf
-rw-r--r-- 1 root root  484 ott  6 14:58 11-evdev.conf
-rw-r--r-- 1 root root  818 ott 10 18:41 40-libinput.conf
-rw-r--r-- 1 root root  529 lug  1  2011 50-device.conf
-rw-r--r-- 1 root root  264 set  2 15:12 50-extensions.conf
-rw-r--r-- 1 root root  527 lug  1  2011 50-monitor.conf
-rw-r--r-- 1 root root  491 lug  1  2011 50-screen.conf
-rw-r--r-- 1 root root 1913 set  2 15:31 70-synaptics.conf
-rw-r--r-- 1 root root  115 set  2 15:37 70-vmmouse.conf
-rw-r--r-- 1 root root 2747 set  2 15:27 70-wacom.conf

Uh, I’m not sure I understand. Is there such thing as a text-mode login manager?
If so, I don’t know what is it on my system. How do I determine it?

Thank you!

it may be easier and quicker just to do a system upgrade from the original DVD,


  • do not allow reformatting of any HDD partitions

  • reselect installed active repos, and keep all non-active repos (from old repos page)

  • reject all repos (from proposed repos page)

  • from the summary page, select to rebuild grub boot menu

if all goes as expected the machine should then reboot to the normal gui

good luck

If I hit ESC during boot I can see that it thinks it has got to the Graphical Interface target,

Post as root:

systemctl status

Oh, this behaviour? Well, I think that it is not you that had changed something, it is Tumbleweed.

I experience the very same behaviour in my tests for direct upgrades from 13.2(fresh install) -> 42.2 and 42.1(fresh install) -> 42.2.

However I have a way to determine if you have fumbled with your settings:
if you are not on production system and have a possibility to change just one setting at /etc/sysconfig/displaymanager, change the DISPLAYMANAGER=“lightdm” to DISPLAYMANAGER=“xdm” and restart the system.
If you get that ugly, old-fashioned but always working graphic login screen, you have done nothing wrong with your settings, it is Tumbleweed in some of its continuous upgrades.

In addition this will confirm that you have the same problem as I do with Leap, prove my suspicions about blank screen with blinking cursor misbehavior root causes, and prove the two workarounds for it

Obviously 10 min. edit is not enough to me.

DISPLAYMANAGER=“lightdm” or whatever it might be to DISPLAYMANAGER=“xdm”