How can one adjust/sync audio and video in gnome-mplayer on fly

How can one adjust/sync audio and video in gnome-mplayer while watching video

The following is my configuration :-
OS : Opensuse 11.2
Media Player : gnome-mplayer 0.9.9

So I use KDE and not Gnome, but are we saying that when you play a video, the audio and video are not in sync? Further, is this only a problem with mplayer and other video players work OK? Depending on your answer, most often the problem is caused by a video driver issue. What video card or chipset do you have? Are you using the built-in openSUSE video driver or have you loaded any proprietary drivers such as the nVidia or ATI ones? If you can play video with say vlc, but just not mplayer. what version of mplayer are you using? Do you have the packman repository setup in Yast. These are just a few questions I would ask on the subject.

Thank You,

I would say that all other video files are working ,fine.These videos were encoded poorly without synchronization and hence i want to sync video and audio by adjusting audio delay

So you are looking for a Video File Editor that works under Gnome that might allow you to re-sync the audio to match the Video. I am not much of an expert on this subject but the following editor (OpenMovieEditor) was recommended to me as working under openSUSE in the Packman repository. I would give it a look-see.

PackMan :: Informationen zum Paket OpenMovieEditor

Thank You,

I do NOT use gmplayer. So I saw this on the internet but I have no idea if it may help: Mplayer video/audio sync fix howto « BLogorrhoea
… still … you could play with it and pass on to us anything that you learn. :slight_smile:

Good idea,but i just want to watch the video,it is a real pain to do video conversions and stuff.I thought the player would have in built functions to delay or advance audio with respect to video

Thanks for the link.Though the settings description was for an earlier version ,i could find the menu in my newer version.It helped to an extent
if we player around with the “audio output” list box

I need something like “Press + or -” to increase/decrease audio lag while playing video file.It is a time consuming process to resync audio and videos through an editor

My experience is that the fault lies with the rip. I have seen this happen several times in the past. The frame rate is detected wrong. The bad news, is I don’t think there is a way to sync it after the fact. The good news is, that I found you can easily fix this by just doing a rip without “decrypting” it. I was never able to tweak the rip to fix this issue, however just by ripping it unencrypted worked fine. It still plays just fine for me and it is synced. Hopefully that will work for you.

Later: Just found this. I think this will do what you want:

re-encoding seems to be a good idea,but re-encoding usually takes up a lot of time :frowning: