How can I use utorrent server(linux version) on opensuse 12.1

I tried ktorrent and got this:
Fri Dec 9 13:14:48 2011: Authentication to : failure
Fri Dec 9 13:14:48 2011: Initiating connection to via (TCP)
Fri Dec 9 13:14:48 2011: Timeout occurred

Every time it’s the same for ktorrent with different ip addresses.
I have got no hope left for ktorrent.

It seems ktorrent has authentication issues, timeout issues, googled it and
found it’s an old bug which seems to be still exists.
] - View topic - KTorrent 3.1.5 does not download anything](

Tried qBittorrent & Deluge, the problem is they cannot contact
all the public trackers at the same time, only one tracker is active
at a time hence download speed varies too much, sometimes as low as 1 kb

## Utorrent contacts all trackers, all trackers are active and I can get
get my expected speed on ubuntu 11.10 (firewall enabled) using utorrent linux version.

Yast2 firewall port is open, even tried with the firewall temporarily
off but no download speed improvement. Followed every steps shown on the link below.

Tried most seeded torrents like openSUSE-12.1-KDE-LiveCD-x86_64.iso.torrent & ubuntu-11.10-desktop-amd64.iso.torrent

I would be very pleased if someone could tell me how to use utorrent server(linux version) on opensuse 12.1
Because I am certain utorrent would do its job as it’s supposed to do.

## Utorrent does not prioritize the trackers and contacts all of them instead, hence it can contact to most
no of peers and deliver a good download speed.

Because native bittorrent clients lack a feature which I presume to be very effictive, that’s why I want to use utorrent server(linux version) .,
So please help me.

Box: 12.1 | KDE 4.7.2 | AMD 64 Athlon II X2 250 | nVidia | 4GB RAM

So download and install uTorrent server for Linux.

Open the installation folder, open the docs folder, pick either the uTorrent_Server.html, uTorrent_Server.pdf, or uTorrent_Server.txt file, open it and read it.

To start the server open a terminal, enter the installation directory, then type ./utserver

In your web browser type localhost:8080/gui into the Address bar. enter admin for the username, leave the password field empty, and enjoy.

You can change the username and password in the Preferences.

Sorry everyone as my post was incomplete.
When I am trying to run ./utserver I get a error " ./utserver: error while loading shared libraries: cannot open shared object file: No such file or directory". I searched for in yast software management but found nothing. Searched for on the internet, downloaded the rpm, installed (?) it. But problem still remains.

How to install properly.

You want to install libopenssl 0.9.8m-6.7.1. I found it by searching YaST for RPM Provides

Now I get these messages, but the server starts and the webui works,

./utserver: /usr/lib/ no version information available (required by ./utserver)
./utserver: /usr/lib/ no version information available (required by ./utserver)

Thanks rafter22 you solved my problem.