How Can I turn Off scrolling effects in Dolphin

I posted before on this problem and Firefox. Firefox is now OK but I cannot get Dolphin to work correctly.
I am using 13.2 x86-64 with KDE 4.14.5 desktop and I have turned off all scrolling options in my Desktop Configuration pages.

The scrolling down a list of directories in Dolphin is almost impossible to use. The scrolling continues long after stopping moving the mouse and so overshoots where I want to stop. Going backwords the same can happen. I am wasting time and effort here. Please can somebody tell me how to stop these effects.

Budgie2

Actually you might want to consider why you are having this behaviour, because it’s consistent with a possible GPU issue IMO

Hi, now there’s a thought. I wouldn’t know where to start looking further but I understand most drivers are built into kernel. Is it possible that something went amiss during installation?

On reflection, Kinfocentre reports for PCI information an AMD/ATI ES1000. A quick google suggests that this may no longer be supported in Linux!!! Help!!!
Budgie2

Here is the list with all AMD repositories: https://de.opensuse.org/SDB:AMD/ATI-Grafiktreiber
Can you test is please?

Add the special repository in Yast and install the driver after that.

Hi and many thanks for the reply and the link. Unfortunately my German is not very good. Is there an english language version available?

BTW I tried the 13.2 link but this took me to the 13.1 page. I would be happy to test but not sure what to do next.

Budgie2

Of course:
https://en.opensuse.org/SDB:AMD_fglrx

Btw, you could have just clicked on “English” on the left side to get to the english version… :wink:

PS: Googling suggests that the ATI ES1000 is very old, comparable to a Radeon 7000 (not HD7000) or the even older ATI Rage. If that’s true it is not supported by the fglrx driver for a long time already (it only supports HD5000 and up).
So you’re out of luck there I’m afraid.

Can you please post your Xorg.0.log to see what driver is actually used?

If the radeon driver is used, you might try to add “nomodeset” to the kernel boot options to disable it. Maybe this will “solve” your problem.
But if your card is only supported by the r128 driver, this won’t help either. And AFAIK this driver might not work properly at all any more.

Yes thanks, I spotted that and tried to edit my post but not quick enough.

Still not much wiser I regret to admit. Bottom line is that the embeded graphics are on server mobo and it may be time to buy a graphics card and put in a slot. I don’t need anything fancy though so if I can get the ES1000 to continue working that would be fine for now.

OK I followed instructions for installation using Yast and installed the fglrx driver. I couldn’t get into Edit mode during boot in order to blacklist the radeon driver so boot went ahead. Seems OK and scrolling problem has gone although scrolling still seems a bit clunky. It no longer has a will of its own however so I am good and very many thanks for all the help.

Hope this feedback is of some help for thoise using old IBM or Dell servers. If anybody can direct me on how to blacklist the open radeon driver please do.
Regards,
Budgie2

There’s no need to manually blacklist radeon when installing the fglrx rpm packages. The packages take care of this anyway.

Seems OK and scrolling problem has gone although scrolling still seems a bit clunky. It no longer has a will of its own however so I am good and very many thanks for all the help.

Hope this feedback is of some help for thoise using old IBM or Dell servers.

I don’t think that you solved anything. If the fglrx driver doesn’t support your card, you actually broke your system.
Please again, post the file /var/log/Xorg.0.log.

If fglrx doesn’t support your card (which it doesn’t seem to), you should not install it.
Installing it does disable radeon, but breaks other things. So if radeon is giving you proplems, you should rather just disable it.

If anybody can direct me on how to blacklist the open radeon driver please do.

Create a file with the contents “blacklist radeon” in /etc/modprobe.d/ or add “nomodeset” (“radeon.modeset=0”) to the kernel parameters (in YaST->System->Boot Loader) to disable radeon.

Hi Wolfi,
OK the log file is quite large (29.5 KiB) so I believe I should upload it somewhere. Will do if you direct me.
Thanks for the blacklist instructions but if it is not needed I shall not do it. Meanwhile no other bad symptoms so not sure why you believe I have not solved anything. I hope the log file will make it clear.
Thanks again for your patience.
Budgie2

Use http://susepaste.org/ or any other pasting or filesharing site.

Meanwhile no other bad symptoms so not sure why you believe I have not solved anything.

Because everything I found on the Internet would suggest that fglrx doesn’t support your card.
And the installation of fglrx breaks Mesa, because fglrx replaces some system libraries with its own versions (just like the nvidia driver btw).

And even if it would not do that, installing fglrx would just unnecessarily take (a lot of) disk space if it doesn’t work anyway… :wink:

I hope the log file will make it clear.

Yes. At least it would show whether you are actually using fglrx now (i.e. it is working with/supports your card) or not.

The important question now is how to undo the fglrx installation and then what next?

Budgie2

Please, do not write your answers inside the QUOTE block.
I completely overlooked them first, and they disappear when you click on “Reply with Quote”.

That is empty.
You have to open the file in a text editor or similar and copy/paste it to susepaste’s text field.

You are correct and the system is damaged. For some reason I didn’t see your original PS post asking for the log file or I might have held off installing the new driver

Well, it’s not really “damaged” per se. But Mesa is not working if fglrx (or nvidia) is installed.

The important question now is how to undo the fglrx installation and then what next?

No, the important question still is whether fglrx is in use/working or not.

You can easily uninstall it by entering YaST->Software Management and removing all packages whose name begin with fglrx. I.e. type “fglrx” into the search field, then right click on the search result list and choose “All in This List”->“Delete”.

And what next: I would suggest trying radeon again (should be used automatically after uninstalling fglrx). But AFAICT after reading a bit, the ES1000 is a 2D-only chip, i.e. it doesn’t provide any 3D/OpenGL support. If KDE is using OpenGL for its desktop effects, this will of course slow down everything (as the 3D software renderer is used) and might cause the problems you described.
So try to set the compositing system to “XRender” instead of “OpenGL” in “Configure Desktop”->Desktop Effects->Advanced. And “Native” instead of “Raster” would be preferable as well I suppose.
Normally KDE should switch back to XRender automatically if there’s no 3D hardware support, but it might not know about your chip and/or the driver might report working 3D support.

If that doesn’t help, try to disable desktop effects completely (on the “General” tab).

I already told you how to disable radeon completely: add “nomodeset” or “radeon.modeset=0” to the kernel boot options.

Hi Wolfi,
I thought I had attached the file before. Now I have opened it and it should be here:-

http://susepaste.org/96400818.

I will send this now and go carefully from now on. Meanwhile I hope this log makes things clear for you.
Thanks again,
Budgie2

As suspected, the log clearly shows that fglrx doesn’t support your card:

  4236.080] (EE) No supported AMD display adapters were found

And Xorg falls back to the generic fbdev driver.

So uninstall fglrx.
And I’d suggest to try with radeon again and the things I posted in my previous post.

Hi, I have uninstalled fglrx after a bit of panic as Yast would not run from GUI but I was able to run it from CLI.
I shall try radeon again and follow your instructions but meanwhile I see that others in my situation just buy another graphics adaptor!

I have several slots available:- 3 no. PCI-E x8, 2 no. PCI-X 64/133 and 1 no. PCI 33. Since I am not a gamer I have never studied these matters and know nothing about the overwhelming variety of options available. I would like an adaptor that sits within the comfort range of my existing power supplies, displays and operating system and does not have it’s own fan. Any views please?

Budgie2

Well, YaST is based on Qt5 now, and Qt5 does use OpenGL in some areas. So the “broken” Mesa might have caused that problem.

Another reason for removing fglrx, no? :wink:

I would like an adaptor that sits within the comfort range of my existing power supplies, displays and operating system and does not have it’s own fan. Any views please?

Well, I’m using a Radeon 9600 here. Works perfectly with the radeon driver, doesn’t have a fan, and you should be able to get one on eBay (or similar) for a few Euros. But unfortunately it is AGP, so of no use to you.

You should try to get a PCI-Express card though. There are PCI cards available as well, but they are harder to get and have of course lower performance (as the PCI slot is slower).

So I cannot really recommend one, but for nvidia cards you definitely should install the proprietary driver (anything starting from GeForce6 should be supported; note that I mean 6, not 600), whereas Radeon cards should work fine with the open-source radeon driver. Although you might need fglrx for brand new models, but as mentioned already it should support all cards starting from a HD5000.

Hi Wolfi,
Many thanks. Not sure I understand significance of “6,_not_600” The 6 series all have numbers 6000!
Is there anything wrong with the 600 series?

Yes.

Is there anything wrong with the 600 series?

No.
But the GeForce 600 series is much newer than the GeForce 6 series (i.e. GeForce 6000 and up).
My point was that GeForce 200 to 500 is supported as well, but GeForce 2 to 5 (again, models with number 4000 and 5000 e.g.) are not.

The numbering can be a bit confusing, that’s why I wanted to point that out explicitely.
Again, supported are GeForce 6 to 9 series (cards 6xxx, 7xxx, 8xxx, 9xxx), and everything in the hundreds, i.e. series 100 to 900 (where the card model numbers are 1xx to 9xx).

AMD cards have a similar “problem”, the latest ones are called R7, R8, and R9, those are supported as well of course, although they might not seem to be “HD5000 and up”.

If in doubt, just ask about a specific model.

But then, I do think that you should get your ES1000 to work satisfactorily as well, especially as you don’t seem to have high expectations (regarding 3D in particular). I cannot say for sure though as I don’t know that card.