How can I test a faulty ethernet connection?

Opensuse 42.1 using NetworkManager on plasma5
Network connection is not working (no link). I test cable and connectors with a cable tester and I find no error.
Ethernet card is a Gb ethernet. Switch is Gb too.
With windows connection works although at 100Mbps

I am testing with ethtool, on boot, with no link


fperal:/home/fernando # ifconfig
eth15     Link encap:Ethernet  HWaddr 4C:CC:6A:6C:E5:02  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:42 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:21474 (20.9 Kb)  TX bytes:21474 (20.9 Kb)

fperal:/home/fernando #

fperal:/home/fernando # ethtool eth15
Settings for eth15:
        Supported ports:  TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Half 1000baseT/Full 
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Speed: 10Mb/s
        Duplex: Half
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: d
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: no
fperal:/home/fernando # 


Then I change cable to a physical connection and get a link


fperal:/home/fernando # ifconfig
eth15     Link encap:Ethernet  HWaddr 4C:CC:6A:6C:E5:02  
          inet addr:192.168.2.195  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::4ecc:6aff:fe6c:e502/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:174 errors:0 dropped:2 overruns:0 frame:0
          TX packets:87 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:24012 (23.4 Kb)  TX bytes:17220 (16.8 Kb)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:681 errors:0 dropped:0 overruns:0 frame:0
          TX packets:681 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:327950 (320.2 Kb)  TX bytes:327950 (320.2 Kb)

fperal:/home/fernando # ethtool eth15
Settings for eth15:
        Supported ports:  TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Half 1000baseT/Full 
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                             100baseT/Half 100baseT/Full 
                                             1000baseT/Half 1000baseT/Full 
        Link partner advertised pause frame use: Symmetric
        Link partner advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: d
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes
fperal:/home/fernando # 



With cable disconnected


fperal:/home/fernando # ifconfig     
eth15     Link encap:Ethernet  HWaddr 4C:CC:6A:6C:E5:02  
          inet addr:192.168.2.195  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::4ecc:6aff:fe6c:e502/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:191 errors:0 dropped:2 overruns:0 frame:0
          TX packets:89 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:25279 (24.6 Kb)  TX bytes:17336 (16.9 Kb)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:681 errors:0 dropped:0 overruns:0 frame:0
          TX packets:681 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:327950 (320.2 Kb)  TX bytes:327950 (320.2 Kb)

fperal:/home/fernando # ethtool eth15
Settings for eth15:
        Supported ports:  TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Half 1000baseT/Full 
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Speed: 10Mb/s
        Duplex: Half
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: d
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: no

And if I change now again the cable to the faulty connection, I get link but at 100Mbps


fperal:/home/fernando # ifconfig
eth15     Link encap:Ethernet  HWaddr 4C:CC:6A:6C:E5:02  
          inet addr:192.168.2.195  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::4ecc:6aff:fe6c:e502/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:259 errors:0 dropped:2 overruns:0 frame:0
          TX packets:205 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:40846 (39.8 Kb)  TX bytes:40083 (39.1 Kb)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1612 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1612 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:761086 (743.2 Kb)  TX bytes:761086 (743.2 Kb)

fperal:/home/fernando # ethtool eth15
Settings for eth15:
        Supported ports:  TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Half 1000baseT/Full 
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                             100baseT/Half 100baseT/Full 
        Link partner advertised pause frame use: Symmetric
        Link partner advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: d
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes
fperal:/home/fernando # 


Network card characteristics


fperal:/home/fernando # ethtool -i eth15
driver: r8169
version: 2.3LK-NAPI
firmware-version: rtl8168h-2_0.0.2 02/26/15
expansion-rom-version: 
bus-info: 0000:01:00.0
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: yes
supports-priv-flags: no
fperal:/home/fernando #

Can i run some more test to find what is going wrong?

regards

What cable length is involved here? Screened cable used? Although the cable continuity check may look good, it may be that the terminations are not as good as as they could be. Gigabit connectivity is extremely sensitive to interference from mains and RF sources, so a good idea to keep away from mains wiring (eg in walls) and transmission sources if applicable.

It’s more or less 2m from the computer to the RJ45 wall socket, 10m through a wireway to the patch panel + 0,5m from the patch panel to the switch. It’s all UTP Cat5e.
Maybe a connection of one of the pairs has some intermittent failure (but when testint with a cable checker I can’t find it) and the card or the driver switch from 1000Mbps to 100Mbps but I wonder two things

  1. Why at boot the card is disabled?

  2. Is it possible with any software tool to test the connection?

regards

How is the NIC configured?

You could force the negotiation to 1000Mbps FD each end and then test throughput with iperf (or similar). Look for errors, dropped packets etc. However, I think you already have an indication that there is a fault and will need to systematically swap out the cables/sockets/terminations until autonegotiation works as expected. It can be tedious but there are no shortcuts to this elimination process. Start with the patch cables. The wall socket may well be the problem too.

The card is configured with static IP, I tested it also with DHCP.
I replaced the wall socket (I think there was some bad connection) and I find that the patch cable was a cat5 instead of cat5e.
Now is working well. iperf reports 942Mbps

thanks

I was actually asking how it was configured with respect to starting at boot etc (as configured via YaST). Anyway, looks like this is sorted now.

I replaced the wall socket (I think there was some bad connection) and I find that the patch cable was a cat5 instead of cat5e.
Now is working well. iperf reports 942Mbps

thanks

Good. Glad to have been of help. :slight_smile: