How can I restore the KDE4 panel?

I’m running openSUSE 11 and KDE4. I did something, I don’t know what, that caused the panel at the bottom of the screen to disappear. I thought I had found a way to restore it, but now when, from the panel, I select “help” and “about KDE” or “about KDE Panel” it says the version is 3.5.9. How can I restore the 4.0 version?

Thank you.

I’ve done that a couple times so far, I’m new at this. I don’t know what caused it either but a reboot brought it back for me.

There are two things that can be done:-

  1. In your KDE4 session you will have to ‘unlock widgets’ (right click on desktop and select ‘unlock widgets’). Now you can right click on the desktop again and select ‘Add Panel’. You should now have a panel at the bottom of your desktop. To this you can add all the widgets that came as default with openSUSE 11.0 by right clicking on the panel and selecting ‘Panel options’ -> ‘Add widgets’ (i.e. Application Launcher, Pager, Task Manager, Show desktop, system tray, digital clock, new device notifier, Lock/Logout and two icons: konqueror and dolphin. To add the icons you have to open the kde4 menu by clicking on the application launcher (green geeko icon) then navigate to the corresponding application, right click on it at select ‘Add to panel’). You can rearrange all these widgets on the panel by individually moving them (Just right click on a widget on the panel and select ‘Start move’).
  2. Alternatively, you can log out of your kde4 session (by right clicking on desktop and selecting leave) and either log in using icewm or hit Ctrl+Alt+F1 on the keyboard. In the command line mode login as the same user (not necessary if using icewm since you have already logged in but needed if you hit Ctrl+Alt+F1). Now enter the following command
    rm .kde4/share/config/plasma-appletsrc
    This will remove the file that stores the configuration of the widgets on your desktop. Now go back to the default login screen: If using icewm just log out or hit Ctrl+Alt+F7 if you had used Ctrl+Alt+F1 before. Now log into your KDE4 session, and you should have the default set of widgets on the desktop as you had when you had first started kde4 on openSUSE 11.0, including the default panel.
    Hope that helps.


upper right corner of the desktop, is there a “hide dashboard” thing? Click it.


Using the information supplied by badshah400, I was able to restore the KDE4 panel. Unfortunately, after using KDE4 for a while I switched back to KDE3 because of quite a few problems I encountered. For example, Dolfin, which I liked, would start to kind of “strobe” after a little while, like an interlace effect, then all of the instances would lock up. I could kill them, but I couldn’t get Dolfin to run again until I restarted openSUSE. I also had other applications failing, where the KDE crash handler would pop up. So, for now I’m back to KDE 3.5.

Thanks for the help.

in openSuse 42.1 I lost the panel after attaching a second display (projector, for a meeting). When I Right-click on the desktop the menu includes “add panel” which then give you the option of ‘default’ or ‘blank’. Choosing ‘default’ gave me my usual panel, as desired. :slight_smile: