How can I restore sound to 10,3

The sound on Open SUSE 10.3 stopped working yesterday after applying a group of 6 security patches. Sound had been working “out of the box” with 10.3. I had been running 11.0 with no sound for a few months and had been unable to get sound even after using the zypper/yast downloads. I tried 11.1 in hopes that the sound difficulties had been fixed, but no luck.

I’m using an ASUS P5NSLI motherboard and SB0400 Audigy2 Value soundcard. That combination continues to work fine in Windows partitions. How can I restore my sound without spending half a day running testing commands and getting downloads? Thanks for your help?

Can you tell us what these 6 security patches were? If you type:rpm -qa --last > lastrpms.txtthat will redirect the output of the rpm command to the text file “lastrpms.txt” and if you open that file with a text editor, you will see a chronological list of the updates that you have done. If you check the last 6 (which are presumably the security patches) we may have an idea as to what you updated that caused the problem.

Please double check your mixer. Audigy sound cards are notorious for stumping users with a simple mixer setting. Take a look here for mixer recommendations: [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA - openSUSE Forums](

Oops – It looks as though there was a lot more than six security patches installed!

xine-lib-1.1.8-14.11 Wed 04 Feb 2009 02:42:22 PM MST
avahi-compat-mDNSResponder-0.6.20-40.2 Tue 03 Feb 2009 07:17:13 PM MST
avahi-0.6.20-40.2 Tue 03 Feb 2009 07:17:09 PM MST
avahi-glib-0.6.20-40.2 Tue 03 Feb 2009 07:17:04 PM MST
amarok-1.4.7-37.6 Tue 03 Feb 2009 07:16:58 PM MST
amarok-xine-1.4.7-37.6 Tue 03 Feb 2009 07:16:48 PM MST
amarok-yauap-1.4.7-37.6 Tue 03 Feb 2009 07:16:46 PM MST
amarok-libvisual-1.4.7-37.6 Tue 03 Feb 2009 07:16:44 PM MST
libpng-1.2.18-15.6 Tue 03 Feb 2009 07:16:42 PM MST
compat-openssl097g-0.9.7g-75.5 Tue 03 Feb 2009 07:16:39 PM MST
audiofile-0.2.6-77.2 Tue 03 Feb 2009 07:16:32 PM MST
sudo-1.6.9p2-23.4 Tue 03 Feb 2009 07:16:29 PM MST

These look like problems to me. It looks like you installed either a Videolan or a Novell/SuSE-GmbH version of amarok and xine-lib.

I recommend instead one install the packman packaged version of libxine1 (instead of xine-lib) and install instead the packman packaged version of amarok, amarok-xine, amarok-yauap, amarok-libvisual, … etc …

There is more detailed guidance here: Check your multimedia problem in ten steps - openSUSE Forums

I’ve replaced the files you indicated with the packmam package, but there is still no sound. The startup and shutdown sounds are missing too. I reinstalled the sound card, but there was no test sound.

I’ve spent about all the time I have for now on this so I’ll be using Windows when I need sound. I’ll get back to this when I get some free time.

Did you check your mixer settings per the guidance here:
[Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA - openSUSE Forums](

Did you work your way through this guide:
Check your multimedia problem in ten steps - openSUSE Forums

Alternatively you could work your way through this guide:
SDB:AudioTroubleshooting - openSUSE

If those links are all too complicated for you, then I can walk you through basic openSUSE Linux sound troubleshooting from the start, but this could take many iterative posts back and forth (as I in essence am then forced to teach you openSUSE Linux sound troubleshooting basics) and that will take time.

I finally managed to restore the sound. It seems that I had previously misinterpreted the illustration of KMix in the KDE3 solution. Correcting that one switch button was all it took. Thanks for your help!