How can I play audio cd's in 12.1

installed 12.1 with KDE desktop. Can’t get any sound from my speakers. What do I do? Which app to use? Kaffeine? Amarok? KsCD? Somebody please tell me what to do. Thanks!

Hi welcome here !!

To start: please don’t use upper-case all over your post’s title. It is considered as shouting, and will stop quite some people from even reading your post. This time I’ll try and see if I can change it for you.

To help you, we need to know a bit more:

  • Did you configure the card during install?
  • Did sound ever come from the speakers after install? System sounds and such?
  • Please open a terminal window, and do:


  • DId you try to configure sound through Yast - Hardware - Sound? If the soundcard is detected, it should show up there. Click it, let it produce a testsound. Report results

Thanks for your help and your etiquette suggestion! We have partial success. I did run the code from terminal and got a long list of USB controllers and other info. Went to Yast and opened the sound configure. I have two drivers listed. Then went to volume settings and turned all volumes up. I can now get test sounds using either driver. Now hat should I do? You’ve got me further along than anything else – Thanks again! oilcanart

Intel(R) Core™2 Duo CPU E7500 @ 2.93GH
4 GB Ram (32-bit only 3Gb usable) – openSUSE 12.1 KDE

I’d like to see the output of the lspci command. From what it looks like your machine has 2 audio cards, and KDE uses the wrong one for the mixer. You can change that in Yast, by setting the card that is now card1 to card0. That should provide the desktop with the correct card and produce sound.

Still, to get full multimedia support, you would have to add the Packman repo and switch from the limited default packages to the full multimedia packages of Packman.

Another thing I just noticed: you run 32bit openSUSE on a 64bit capable machine. Any reason for that?

For configuring multiple sound devices in openSUSE with pulse audio enabled, I like to use the application ‘pulse audio volume control’ (pavucontrol) which one needs to install if using KDE (it is in the nominal OSS repository). I blogged about it here, providing examples: Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

All is well! My new friends, Knurpht and oldcpu will get a big laugh, but I wasn’t aware that had a 64-bit machine. I wondered about it, but wasn’t sure – so I re-loaded with my 64-bit disk. Now, after checking the sound card configurations, I am listening to a CD played by Amarok. I will be learning how to fully use it in the next several weeks, but for now I’m doing well.

Once again, my very best thanks to everyone. Just for your curiosity, I’m from 1943, and not really into PC’s except for home use and at work. I’m a chemist doing gas chromatography for specialized sulfur analysis. I want to try Linux to get away from MicroSoft tyranny. Looks as if I’m into a learning experience! If you wish, contact me at Thanks again!