How can I multiboot an USB drive?

I was hoping that someone on this forum could help me to multiboot my USB drive with openSUSE 11.4 and Ubuntu 10.10. I would also like the changes I make to the files and settings on my operating systems which are located on my flash drive to be persistent. I am a bit of a Linux noob so I was hoping for some easy, basic, step-by-step instructions on how to do this. Also, I do not mind using a terminal or other similar applications but I would prefer otherwise as I do not want to mess up.

UNetBootin & a Lifehacker, tips and downloads for getting things done search should put you on the right path.

I have tried searching on the site for a way to do this but it does not seem that UNetBootin can allow me to multiboot on my USB drive or be able to allow my files and settings to persist. I have also found a program called YUMI which is a multiboot USB creator but after trying it I have not been able to find a way to get it to work with openSUSE 11.4 and it appears that Ubuntu is the only Linux distribution that it will allow persistence for.

Sorry, I had the wrong tool but I knew they did an article. Lifehacker, tips and downloads for getting things done

Well all of my information is out of date, YUMI replaced my MultiBootLoader.
As for the persistence, partition your USB stick manually (I believe you can do this via Yast) into two partitions, one for your OSes, which you would use YUMI for, and one for data. The data partition would be persistent.
The above link says openSuse is quite possible, but like I said, YUMI is more recent.

What you have mentioned could work but my biggest concern is that I know that openSUSE makes three partitions when installed and I wonder if it would therefore not read from the data partition. If so then your method would work for Ubuntu but not openSUSE which would give me the same result although slightly more complicated then if I use YUMI to multiboot the two. I would like to say that YUMI does work in multibooting openSUSE even though it is not listed, the trouble is the persistence as it will not allow for that on any non Ubuntu distro.

unetbootin works well for ubuntu live cd iso.

Could you elaborate on openSuse’s 3 partitions? If you’re thinking one for root and one for home, they can be consolidated, and you won’t want swap on the USB.

YUMI shouldn’t even know about your persistent data partition. You will probably have to manually add it to your fstab once you get the OS up and running.

You’re right I forgot that I could put them on the same partition. Thanks for your help it works fine now.

Do you mind posting a skeleton walk through of what you did to point any other people looking for this information in the right direction?

this is the way to do it

MultiSystem – Create a MultiBoot USB from Linux | USB Pen Drive Linux

Here is a short and basic walkthrough of what I did.

  1. I downloaded YUMI from YUMI - Multiboot USB Creator (Windows) | USB Pen Drive Linux
  2. I downloaded the newsest version of openSUSE and Ubuntu from their respective webpages (I should also note that I am using gnome in Ubuntu and KDE in openSUSE if that matters for our topic).
  3. I ran the YUMI program and first installed Ubuntu using the persistence option set to approximately 2000MG
  4. Next I installed openSUSE from YUMI as I would normally.
  5. I closed out the program when it was finished installing and created a partition for data on my USB drive using any number of programs from the internet (There are tons of programs to help you partition your USB drive).
  6. I then created a partition for data on my flash drive.
  7. I set my computer’s BIOS to prioritize booting from external devices (note that this may be different depending on your computers BIOS)
  8. Relax and enjoy your persistent, multibooting USB drive.

Step 3: In YUMI I don’ t have option tu set persistence during UBUNTU installing.

Did you ever figure this out? I’ve yet to be able to get persistance to work under a multi-boot setup either. All of the directions I’ve found so far have the same line. Telling you to use the option to set persistance under Yumi and that just doesn’t exist.