How can I make X11 screens be side-by-side?

It used to be a sysadmin/yast setting wherein you configured the display.
It is now done under “personal settings”–>“display” meaning ordinary
users can set their own preferences. That’s really nice and all, but
I’d rather it be sysadmin-only than have to go through several minutes
of futzing around with it every blasted time I login. So, how can I
make side-by-side permanent either for myself or for all the people
who use my system (just me)? Thank you.

Some possible hints: The “Multiple Monitors” under the system settings says,

This module is only for configuring systems with a single desktop spread across multiple monitors. You do not appear to have this configuration.
Since I obviously do and since I can get the desktops to spread across the monitors (after futzing for several minutes), I really do not know what to make of this comment.

Go take a look at this post it’s mine and i have dual monitors. This is part of my xorg.conf file.

Xorg config file

If this does not help post what you have in your xorg.conf file and i’ll see what might be wrong.

Thank you. I am sure that part of my confusion lies with the fact that I do not have
a /etc/X11/xorg.conf file any more. Somebody has gotten Really Clever. There’s no
more sax2 either. “It’s all automatic.”

This worked in openSuSE 11.2:

Section “Monitor”
Identifier “Monitor0”
DisplaySize 474 296
HorizSync 30-81
ModelName “SYNCMASTER 225BW”
Option “DPMS”
Option “PreferredMode” “1680x1050”
VendorName “SAMSUNG”
VertRefresh 56-75
UseModes “Modes[0]”

Section “Modes”
Identifier “Modes[0]”

Section “Device”
BoardName “Framebuffer Graphics”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
Option “SaXDualHead”
Option “TwinView”
Option “SaXDualMonitorVendor” “SAMSUNG”
Option “SaXDualOrientation” “RightOf”
Option “MetaModes” “1680x1050,1680x1050;1600x1024,1600x1024;1600x1000,1600x1000;1400x1050,1400x1050;1600x900,1600x900;1280x1024,1280x1024;1440x900,1440x900;1280x960,1280x960;1366x768,1366x768;1360x768,1360x768;1280x800,1280x800;1152x864,1152x864;1280x768,1280x768;1280x720,1280x720;1024x768,1024x768;1280x600,1280x600;1024x600,1024x600;800x600,800x600;768x576,768x576;640x480,640x480”
Option “SaXDualResolution” “1680x1050”
Option “TwinViewOrientation” “RightOf”
Option “SaXDualMode” “Xinerama”
Option “SecondMonitorVertRefresh” “56-75”
Option “SaXDualHSync” “30-81”
Option “SaXDualMonitorModel” “SYNCMASTER 225BW”
Option “SaXDualVSync” “56-75”
Screen 0
VendorName “VESA”

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 16
Modes “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 24
Modes “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 8
Modes “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”

This is “xorg.conf.d/50-monitor.conf”

Section “Monitor”
Identifier “Default Monitor”

If your monitor doesn’t support DDC you may override the

defaults here

#HorizSync 28-85
#VertRefresh 50-100

Add your mode lines here, use e.g the cvt tool

And 50-device.conf:
Section “Device”
Identifier “Default Device”

#Driver “radeon”

Required magic for radeon/radeonhd drivers; output name

(here: “DVI-0”) can be figured out via ‘xrandr -q’

#Option “monitor-DVI-0” “Default Monitor”

and 50-screen.conf
Section “Screen”
Identifier “Default Screen”

Device “Default Device”

Doesn’t help for radeon/radeonhd drivers; use magic in

50-device.conf instead

Monitor “Default Monitor”


I’m not an X11 expert and I really don’t want to be. Should I just
copy in the old config and hope for the best? I doubt it. The NVidia
driver won’t compile. Extract from /var/log/nvidia*.log:

-> Kernel module compilation complete.
ERROR: Unable to load the kernel module ‘nvidia.ko’. This happens most
frequently when this kernel module was built against the wrong or
improperly configured kernel sources, with a version of gcc that differs
from the one used to build the target kernel, or if a driver such as
rivafb/nvidiafb is present and prevents the NVIDIA kernel module from
obtaining ownership of the NVIDIA graphics device(s), or NVIDIA GPU
installed in this system is not supported by this NVIDIA Linux graphics
driver release.

   Please see the log entries 'Kernel module load error' and 'Kernel
   messages' at the end of the file '/var/log/nvidia-installer.log' for
   more information.

-> Kernel module load error: insmod: error inserting ‘./usr/src/nv/nvidia.ko’:
-1 No such device
-> Kernel messages:
14.960190] type=1505 audit(1279674048.181:10): operation=“profile_load”
pid=1682 name=/usr/sbin/ntpd
15.032296] type=1505 audit(1279674048.253:11): operation=“profile_load”
pid=1683 name=/usr/sbin/traceroute
17.036198] powernow-k8: Found 1 AMD Phenom™ 9550 Quad-Core Processor
(4 cpu cores) (version 2.20.00)
17.036253] powernow-k8: 0 : pstate 0 (2200 MHz)
17.036255] powernow-k8: 1 : pstate 1 (1100 MHz)
17.647222] alloc irq_desc for 29 on node 0
17.647226] alloc kstat_irqs on node 0
17.647236] forcedeth 0000:00:0a.0: irq 29 for MSI/MSI-X
18.018016] Bridge firewalling registered
18.028887] device eth0 entered promiscuous mode
18.033916] br0: port 1(eth0) entering forwarding state
19.153675] NET: Registered protocol family 17
28.144393] br0: no IPv6 routers present
28.493144] eth0: no IPv6 routers present
38.866950] BIOS EDD facility v0.16 2004-Jun-25, 3 devices found
93.654451] nvidia: module license ‘NVIDIA’ taints kernel.
93.654456] Disabling lock debugging due to kernel taint
94.274301] NVRM: The NVIDIA probe routine was not called for 1
94.274305] NVRM: This can occur when a driver such as rivafb, nvidiafb
94.274306] NVRM: rivatv was loaded and obtained ownership of the NVIDIA
94.274307] NVRM: device(s).
94.274310] NVRM: Try unloading the rivafb, nvidiafb or rivatv kernel
94.274311] NVRM: (and/or reconfigure your kernel without rivafb/nvidiafb
94.274312] NVRM: support), then try loading the NVIDIA kernel module
94.274315] NVRM: No NVIDIA graphics adapter probed!
ERROR: Installation has failed. Please see the file
‘/var/log/nvidia-installer.log’ for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at Welcome to NVIDIA - World Leader in Visual Computing Technologies.