How can I install Nvidia drivers in OpenSuse 11.3

Hallo:

I’m trying to install Nvidia drivers in OpenSuse 11.3

When I run NVIDIA-Linux-x86-185.18.36-pkg1.run file, I receive this error.

ERROR: The kernel header file
‘/lib/modules/2.6.34-12-desktop/include/linux/kernel.h’ does not exist.
The most likely reason for this is that the kernel source path
‘/lib/modules/2.6.34-12-desktop’ is incorrect. Please make sure you
have installed the kernel source files for your kernel and that they are
properly configured; on Red Hat Linux systems, for example, be sure you
have the ‘kernel-source’ or ‘kernel-devel’ RPM installed. If you know
the correct kernel source files are installed, you may specify the
kernel source path with the ‘–kernel-source-path’ command line option.

I’ve installed kernel-source, kernel-devel, gcc, make

My card: nVidia Corporation G86 [Quadro NVS 290] (rev a1)

What do I have to do to install Nvidiar driver?

Thanks.

Add the nvidia repository to yast 2 and install the proper driver by the yast2 packet manager. Please be sure that you boot with the option nomodeset and have blacklisted the nouveau driver.

And if you really want to do it the wy you described it, then you need the package kernel-syms installed.

torcaz99 wrote:

> When I run NVIDIA-Linux-x86-185.18.36-pkg1.run file, I receive this
> error.
>
> My card: nVidia Corporation G86 [Quadro NVS 290] (rev a1)
>
When I go to nvidia.com and select exactly your graphics card it tells me to
download version
256.44.
So how do you come to the conclusion to use this older driver which is most
likely incompatible with the kernel and xorg anyway?


openSUSE 11.2 64 bit | Intel Core2 Quad Q8300@2.50GHz | Gnome 2.28 | GeForce
9600 GT | 4GB Ram
openSUSE 11.3 64 bit | Intel Core2 Duo T9300@2.50GHz | Gnome 2.30 | Quadro
FX 3600M | 4GB Ram

yes, you are right. The driver i downloaded was old (I followed a post in a forum whose link downloaded that version).

Now I’ve followed instructions in (cant use 1-click, it uses ftp and I can use only http):
SDB:NVIDIA the hard way - openSUSE

and it has worked

Thanks for your help