How can I install my USB M-audio card drivers?

Hi, I’m new to linux, and got several problems during installation hardware.
Especially with my soundcard - M-audio Mobile Pre USB.
I typed “lsusb” in terminal and got it third in the list:
Bus 003 Device 003: ID 04e8:341b Samsung Electronics Co., Ltd SCX-4200 Series
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 0763:200f Midiman M-Audio MobilePre
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 09da:000a A4 Tech Co., Ltd Port Mouse
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

But when I want to get it in the alsaconf command it wont work. :frowning: There is only some sort of “intel hd audio” soundcard which one I dont have on my laptop.

I also heard about snb-usb-audio option for Alsa, but still I’m newbie to linux Os (I decided to choose openSuse 11.1) and don’t know how to activate it for Alsa to see my USB soundcard.

Sorry for my english and please help if you know how to solve problem.

Your english is OK. The hda-intel (that’s it) is probably the onboard audio chip your laptop came with. You should be able to see it with ‘lspci’.

AFAIK you can add it in Yast - Hardware - Sound, and tell it to use the snd-usb-audio kernel-module. After that you set it to be the primary card and then it should work. At least it did with my Logitech USB audio stuff. Don’t have an M-Audio to test with.

Thank you very much for answering.
But please tell me - how to activate snd-usb-audio in YaST? I’m totally newbie in linux, and I think I gor wrong when choosed “usb audio” in YaST and tried to add parameter in advance options: “snd-usb-audio, value 1”.
Of course it told me that parameter “snd-usb-audio” can not be of value 1. I managed to delete this parameter and just tried to install “usb audio” driver. Of course I didnt get any sound from my M-audio Mobile Pre.
If you may, please tell me how to activate what you’ve said in “for newbies” manner.

While not a headphone per-se, is there anything in this wiki that helps:
USB headphones - openSUSE

… the top level openSUSE audio troubleshooting guide is here: SDB:AudioTroubleshooting - openSUSE

and since you stated you were new, … some openSUSE concepts: Concepts - openSUSE

… also, do not forget to read our openSUSE-11.1 Installation Stickie - as even after installation, there is useful information there, especially wrt setting up repositories (ONLY 4 : OSS, Non-OSS, Update and Packman - do not leave any others enabled any longer than necessary): NEWBIES - Suse-11.1 Pre-installation – PLEASE READ - openSUSE Forums

Thak you too, all this information you gave me links to, is very useful and important to such a newbie like me. I’ll try all the solutions for having sound and report if I will or wont get sound.

I forgot to say - this time I logged out from Linux I had a message in the upper right corner of the screen, it said something like this:
“Phonon hasn’t loaded, returning from “Intel smthn” sound device to M-audio Mobile Pre (!)”
And then I had sound of shutting down the system from my USB soundcard!
Of course after shutting down system I immidietly turned it on again, but, unfortunately, I had no sound from my Mobile Pre soundcard and no sound at all from somewhere.
Maybe this strange behavior of sound drivers\systems can tell something about problem?
Also I read about sound troubleshooting and tried some ways. They didn’t help.

The sound troubleshooting guide gives 3 ways to test your audio, and you should try all 3. IF ANY of the 3 work, then your problem is likely codecs or crippled applications.

The trouble shooting guide also asks you run a diagnostic script. Did you? If so, please post the URL here that the script provides.

Oh, I’m really sorry, I did something wrong and asked again and again you about the problem, but I just solved it quickly an easy.
I added USB audio, as I said, in YaST->Hardware->Sound, an just leaved it with no snd-usb-audio option cause it said it had wrong parameter. USB audio soundcard was 0; then, I forgot (!) that my Intel smthn HD audio (it was - 1) - is not really working, cause it’s not set up. I just made auto-set up for it and then chosen my USB audio soundcard to be primary card. Then… At least, my M-audio Mobile Pre started to work!
Thank you all for answers, now I can fully enjoy linux with music (cannot live without it)!

Glad to read its working !

OpenSUSE documentation (and user guides) is weak in the area of USB audio, and its an area I do not know enough about to help.

I’m exchanging emails with a friend, who has Ubuntu-9.0.2 w/KDE-4.3 (don’t ask me how he got KDE-4.3 on Ubuntu-9.0.2) installed on one of his PCs, and also openSUSE-11.1 w/KDE-4.3. He has a USB mic, and when he inserts it on openSUSE-11.1 there is no automount pop-up and it does not work. When he inserts it in Ubuntu-9.0.2 it is recognized with a pop up and the mic works.

I suggested he reboot his PC to openSUSE-11.1 with the mic plugged in during boot. He tried that, and in that case, the Mic does work on openSUSE-11.1. :slight_smile: … Hence he has a work around, albeit its not a pleasant work around. So there is something wrong with the hot plug automount of this USB mic under openSUSE Linux.

But I don’t know enough about hal/udev, nor about USB audio devices to help him improve this.

I suggested he write bug report on openSUSE-11.1, but I don’t think that is what he wanted to hear when he asked for help from me.