How Can I Install Codecs?

Hi, Im a newbie in openSUSE project. I have problem. I can’t install mp3 codecs and VLC media player. How can i do this?
im trying “zypper install vlc” but this is not working.

See this.

Multi-media and Restricted Format Installation Guide

After you used that guide mentioned by reo_sam, I suggest you use this tool to have the best multimedia experience : MultiMedia Checker or mmcheck - Check Your openSUSE MultiMedia Setup in Just 16 Steps

With two ways 1)from terminal
with

 su 
# zypper install <codec>

and through yast
just write the codec who you are looking for in seach gap and that’s all.

Here is your codec who you need http://opensuse-community.org/codecs-kde.ymp

For vlc try to install videolan repository

 su 
# zypper addrepo -f http://download.videolan.org/pub/vlc/SuSE/<openSUSEversion> VLC
# zypper mr -r VLC
# zypper install vlc

Hi stamostolias,

it is better for him to use the tool developped by jdmcdaniel3. it is simply a great tool to know what is missing.

thanks its done. I have more of a problem.
I cant mount my other discs.

How can i do?

fdisk -l

Disk /dev/sda: 250.1 GB, 250059350016 bayt
255 heads, 63 sectors/track, 30401 cylinders
Units = silindir of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0005758d

   Aygıt Açılış    Başlangıç     Bitiş  BlokSayısı Kml Sistem
/dev/sda1   *           1        5223    41945088   83  Linux
/dev/sda2            5223        9139    31455232   83  Linux
/dev/sda3            9139       30402   170797056    c  W95 FAT32 (LBA)

Hi,

So you want o mount sda3, that’s right ? Are you with KDE or GNOME ? In terminal :

mount /dev/sda3 /media/the_name_you_want

Assuming the /media/the_name_you_want directory exist.

@Daaax correct. But if i dont root, i cant copying files… :frowning:

Im with KDE terminal

As i see the third parition has w95. Of course and you can not mound your third HDD. Format it.

But I dont mount SDA2. Actually doing but without being root i cant copying files

Have a look at this:
openSUSE: HowTo set disk access permissions for Fat32 (VFAT) on a desktop PC
With the extra options in the mount command you can copy files to it as your normal user.

/dev/sda3            9139       30402   170797056    c  W95 FAT32 (LBA)

Are there people who use windows 95?:::
Very strange!!!:\

Hi bariuse,

If you want to do it graphically, install ntfs-config. it should do the trick :

zypper in ntfs-config

@stamostolias
This is a Standart FAT32 shown :slight_smile:

Daax for me it didnt :frowning:

Hi barisuse

Use the YaST > System > Patritioner tool to locate this partition. Click on the windows partition (it will be in the list presented), then ‘Edit’. You can configure so that it mounts at boot with user r/w access. It will create the required /etc/fstab entry for you.

Hi deano_ferrari,

Let’s hope it works for him. The time I was with KDE4.5.2, I did it this way and it never worked. :\

I’ve never had a problem with it. However, additional access policies (which can set at installation time) will influence default access (eg if set to paranoid for example), so may require post-install adjustment.

For KDE 4.6, there is System Settings > Actions Policy (similar config exists for earlier KDE releases) where policies can be adjusted if required.

Hope it works better in 4.6 than in 4.5. It simply doesn’t do what tis supposed to. :\

This is a Standart FAT32 shown

Ok then!!! Sorry!!!