How can I get Kmix to control volume through HDMI?

I have my Acer Revo R3610 PC connected to my LCD TV through HDMI. The sound works but I cannot control the volume from Kmix. I’ve added the IEC958 channel to the channels in Kmix but it doesn’t provide a slider for it. Only a mute. The master volume slider has no effect at all. Is there any way of controlling the volume when connected through HDMI?

I ran the alsa diagnostics script (/usr/sbin/ and uploaded it here.

Here is a quick summary of my Alsa version, sound module loaded and sound card details.

mediacentre@mediacentre:~> cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version

mediacentre@mediacentre:~> cat /proc/asound/modules
 0 snd_hda_intel

mediacentre@mediacentre:~> cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfae78000 irq 20

You did not indicate your desktop or openSUSE version. I am using KDE 4.4.4 on openSUSE 11.3 and if I open the KDE menu / Personnel Settings / General Tab / Computer Administration / Multimedia on the bottom left. I have “Show advanced devices” checked. When I select music or video on the middle left tree you should have “Standard PCM Playback” first, then followed by “IEC 958 (S/PDIF) Digital Audio Output” as second. The exact verbage may differ for your sound card, but placing the Digital output as first seems to disable the ability to control the volume. I also have selected xine at the top backend. Making a change here often requires you to end and restart your current KDE session for it to be seen as a change.

Thank You,

Thanks. I was so busy trying to get he other information together that I forgot to include the basic stuff :stuck_out_tongue:

Yes I am using KDE 4.4.4 on 11.3. I tried your suggestion and I still cannot adjust the volume. I’ve posted screen shots of my sound output devices in the Multimedia settings. I’ve also attached an image of my kmix controls.

I don’t get any sound at all if I place anything else at the top of the list.](

For some reason I have thee IEC958 devices. Only the second one IEC958 2 is active. The other two IEC958 and IEC958 Default PCM seem dead, i.e. the don’t mute the sound if I tick mute.](

The last time I tried using nVidia Audio was for a GT 240 card which included HDMI and I had trouble making the audio in it work at all. Video was fine of course.

So, if you put the one and only entry that uses the word analog at the top of your preferred list, you get no sound or it just can’t be adjusted with your sound control? It does look like there are three HDMI digital entries and I guess I would put the two (hard to say which except the gray one looks unusable) that don’t work at the bottom of the list.

Thank You,

Putting anything else, other than what is shown on my screenshot, at the top of the list produces no sound. But I don’t have any cable plugged into the analogue sound output on the PC so I assume that is why I don’t hear sound from the analogue device. I am just using the HDMI cable for both video and sound as I wanted digital sound.

Before I tried using HDMI for sound and video I was using the analogue sound output from the PC with no sound problems at all. It seems it’s the digital sound that I cannot control the volume of.

The ability to vary the sound level through HDMI, which is just coaxial audio, is a function of the sound chip and normally, this level is constant. For instance, my cable box has HDMI output with Dolby Digital 5.1 and PCM stereo and it does not allow any level adjustments, only the RCA analog stereo Outputs can be adjusted. On my Linux PC I use an (old) Creative Labs Sound Blaster Audigy sound card (with I/O Extension card). As long as the audio type is PCM stereo, I can adjust the audio level out on my coaxial audio output as long as I keep the PCM output selection on top of the SPDIFF output (In the KDE Multimedia Selection) even as I still can get Dolby Digital 5.1 to work. When in the Dolby Digital passthrough mode, level controls do not work, as one might assume would be the case. If I should place SPDIFF Digital Audio on top of the List, the Audio level can not be adjusted, even in PCM stereo mode, just as in your case.

In any event, your setup may be normal for the included sound chip you are using.

Thank You,

Thanks. What you say now makes sense. I’ll use the analogue sound for ‘normal’ sound duties and leave the hdmi for the digital 5.1 duties.

Happy to speak with you online suse_tpx60s and thank you very much for the reputation addition. It is very much appreciated. You have a great day and please come back and ask for any help that you require.

Thank You,