How can I enable ethernet at startup with NetworkManager

Hello

How can I enable the network with Networkmanager WIHTOUT logging in in OpenSuse 11.2?
If I define a connection for ethernet the System connection is greyed out :frowning:
I want to use Networkmanager because I have also wireless connections…

Thanks a lot

Beat

Hi,

I set up a wireless connection that connects automatically without me
logging in to 11.2, I think there is a ‘system wide connection’ (or
similar) option when you go into ‘manage connections’ and ‘edit’ the
connection.


Regards,
Barry Nichols

That’s the problem. It’s greyed out and you cannot enable this option. Not even as root :frowning:
Why could this be?

Look carefully in the configuration for your connection, there is a check box for connect automatically

I found this shot I did some time back
http://thumbnails18.imagebam.com/4488/657c4144876656.gif](http://www.imagebam.com/image/657c4144876656)

Hi,

Sounds like you logged in and tried to change this as root. Never log in
as root.

I just checked my KDE Laptop and it’s the same, unable to select.
The PC I enabled it for is using GNOME.

I had a quick search around and I can’t see how to enable it in KDE.

the config file for knetworkmanager is
‘~/.kde/share/config/knetworkmanagerrc’, but I couldn’t find anything
there either.


Regards,
Barry Nichols

caf4926 <caf4926@no-mx.forums.opensuse.org> writes:

> Look carefully in the configuration for your connection, there is a
> check box for connect automatically

OP knows about that, we are trying to enable the ‘system connection’
option below it, that is also greyed out in your image.

Any idea how to do it?


Regards,
Barry Nichols

OK, sorry Barry.

No idea.

I would have thought ifup was the way to manage this, you can configure wired and wireless with ifup.

I don’t think you should never login as root.
I think it’s logical that only root of a machine can enable a system wide network connection and not the normal user …
But of course I have first try to set it as normal user …
But as noted now from others there is no way to set this?
Is this reported as bug?

So if I’m right the only solution is to disable NetworkManager and us traditional ifup method…

What have we to track to be up-to-date of this problem?

It is the other way around. It can not be possible that a login in the GUI as root is needed for any configuration. Thus do not log in as root.

The normal way to start a network interface a boot (runlevel 3 and above) is of course the ‘traditional method with ifup’. This can be done for ethternet and wifi. As this is impossible to do for the labtop enduser who wants to choose between available wifi connections after login network managers were invented and they work from within the ed-user GUI by design. But I can not tell you a way to change between these two methods on … on what realy? How would the system know what you want to use today?

I was curious as how to do this as well. My goal was to at the log on screen, instead of logging into KDE, I wanted to log into the console and see if I had Internet. Even with my knetworkmanager on “auto”, im not using the yast network manager. There was no internet, I tested it by doing zypper install lynx. I don’t think knetworkmanager even initializes till you boot into KDE, so even with auto-set, you would not get internet in the console

So then I found this info online

  1. Log into console

  2. su -

  3. ifconfig wlan0 up

  4. iwconfig wlan0 key your_key_here

  5. iwconfig wlan0 mode Managed

  6. iwconfig wlan0 essid your_essid_here

  7. dhclient wlan0

My friend did that on his laptop and it worked perfect! He was able to download and install lynx without going into KDE. I tried to do this real quick with my desktop at home before leaving to work. It didn’t seem to work, perhaps in KDE you have to give yast the network management first, instead of knetworkmanager in order for you to log into console first, and enter these commands with success?

I’ll have to try this with eth0 since im at work and on a lan. I hope this helps ya out! Not sure how to automaticly do this though.

This is doing by hand what either the init.d script does on reaching runlevel 3 and above, or what network manager does after being started from the GUI. I thought the OP asked for something automatic bringing up his interface.

So the commands I just typed are what init.d does automaticly before you boot up KDE? So is init.d not doing this automaticly because his gui network manager is given the permission for managing the network? So if you give yast the network permission over network manager, will init.d automaticly load the commands I typed before you log into KDE so internet will work logging into console?

Man I hope that made sense/you can understand what I’m asking:shame:

That is true. When you configure in YaST to use ‘traditional method with ifup’, YaST will put the appropriate parameters in /etc/sysconfig/network/ifcfg-… (and other files there for routing, etc). It will see that the script starting/stopping the network in the* /etc/init.d* directory s linked to from the rc directories for runlevel 3 and 5. Thus at every boot this script runs and it will use the config files to execute the same commands (or very similar like *ifup *instead of ifconfig, but that is only detaiils) to achieve what you achieved.

How do you think this would function otherwise? Magic?

You can see w hat all these tools do by reading teir man pages

man ifconfig

etc.

This so called 'traditional method" is the 'normal method te be used in every computer room or desktop system, cabled or wifi.

I think it’s pretty clear.
If no user is logged in the system wide default is on.
If a user login and changes the connection with NetworkManager this is the new one…
What I have noticed is very nice with the networkManager…
If I configure ethernet and wireless the default gw if from ethernet. Now if the ethernet is down the wireless default will be the new gateway and if ethernet comes back the ethernet default gw is again de the used one.
This is realy how it should work in my opinion: Very very nice!! Thanks to the developers and maintainers!!!
The only bad thins is realy that you must login.
So if you reboot the device remotely how do you login??? And now don’t tell me that you are always in front of you laptop…
I go out of house and have forgotten something…
Wakeup on lan and that’s it …
Login remotly and get the stuff (ok with os10.3 it was so …)

My 2 cents again about this problem …