How can I downgrade my kernel to 4.1 (Leap's) and lock it?

I use Tumbleweed GNOME.
After kernel update to 4.5.x, my system cannot open. After a little search online, I found out that my VGA has the problem. My card is:

00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 7340] [1002:9808]

For temporary solution, at GRUB, I opened with the kernel

4.4.3-1-default #1 SMP PREEMPT Fri Feb 26 09:54:10 UTC 2016 (171b8f1) x86_64 x86_64 x86_64 GNU/Linux

I set my boot options on yast to boot with that kernel and it works. I also did what the wiki says (not sure if I did it correctly).

My idea was to install Leap’s kernel (I guess it’s 4.1) and make it upgrade only that kernel.
Is that possible? How can I do that?

Bad idea mixing OS version.

So first were you using a proprietary driver? if so you have to reinstall it.

I used open driver. Did’t install anything extra.

Mixing kernels you mean. I don’t mean save kernel from leap and install it on tumbleweed somehow. I want to install previous kernel from tumbleweed repositories.

It has probably gone, long ago. That’s the way that a rolling distribution works.

You can use this repo to get Leap’s kernel though:

Give it a higher priority (i.e. lower priority number) than the standard repos, and zypper should only install the kernel from there I think.

If not, you could lock (i.e. prevent installation of) kernel-default from repo-oss like this:

zypper al -r repo-oss kernel-default

(you need to adapt the repo name accordingly of course)

Note that I haven’t tried this…

Another “solution” to your actual problem might be to install fglrx. But that might have other problems, especially with the constant kernel and Xorg upgrades in Tumbleweed…

I’m not so sure about that. I have the update-test repo configured (for 42.1), with priority 101. So nothing should ever be installed from there if the priorities worked. But “zypper up” wants to install the latest kernel from there anyway. It’s looking as if kernels are special, probably related to the multi-version setup.

So I disable that repo before actually doing a “zypper up”. Then I re-enable it when I want to again peek at what is being tested.

But the Kernel:xxx repos have a different vendor, unlike the update-test repo.

So if you uninstall the kernel packages from the standard repos, “zypper up” should not want to update the installed package with the one from the standard repo with a different vendor. (I think, but I’m not sure because of the kernel multi-version thing, that’s why I mentioned the lock as well)

Also, another difference here is that the update-test repo contains explicit “patches”, while in the main Tumbleweed repo the packages are just updated in place. This might also cause different behaviour.

Everything in the update-test repo has patches. But only kernels ignore the repo priority (when using “zypper up”). However, it does look as if “zypper patch” will install all patches regardless of repo priorities.

In any case, changing the “enable” flag is a sure way of preventing unwanted updates from a repo.

Right. Probably related to multi-versions.

But the situation might be different if the higher version is from a different vendor (again, the update-test repo has the same vendor as the standard repos, but Kernel:xxx has a different vendor).
I’m not sure though.

However, it does look as if “zypper patch” will install all patches regardless of repo priorities.

Yes, that’s what I expected.

In any case, changing the “enable” flag is a sure way of preventing unwanted updates from a repo.

Ok, but the OP wants to prevent the kernel from the main repo getting installed. Not really a good idea to disable that repo… :wink:

In the multi-version settings, set it to keep the oldest kernel. That way the desired one won’t be accidentally deleted.

When the desired kernel is updated, then manually delete that, so that it’s update becomes the preserved oldest one.

I followed that practice with the old Tumbleweed (based on 12.3 and 13.1). It allowed me to be sure that I always kept a kernel from the base system (the 12.3 or 13.1).

I would suggest just adding the Leap OSS repository ( and then install the kernel from there. You can find the version you want with

zypper se -v kernel-default
zypper in kernel-default-#.#.#-#.#

Then, you can add a lock to kernel-default for a specific repository or globally.

Also not a bad idea, but I don’t want zypper updating my GRUB every time it installs a new kernel (even if I don’t want to use it).

Sorry, I would strongly advise against that.

This can easily break your system.
(and of course it will take space on your hard disk for the package information cache, and it will take time to refresh that repo, which contains a lot of packages)

It’s unnecessary and overkill for just getting Leap’s kernel.

You can install the kernel from Leap’s standard repository if you want, but better download the package manually and install it with “rpm -i”.
You can even specify the full URL to the package and rpm will download it automatically:

rpm -i

OTOH, this thread was started months ago. The problems with the (then) current kernel are hopefully fixed by now… :wink:
Tumbleweed has moved from kernel 4.5 to 4.8 meanwhile.

I use the thread as I found no more appropriate one. Obviously I don’t want 4.1.

I want to use the commercial Intel vTunes profiling tool which does not officially support openSUSE.
I cannot compile the required vtune kernel drivers with the current TW kernel 4.15, but I believe it worked with 4.12

What is the best way get a 4.12 kernel?


I find the community package home:dsterba:kernel:v4.12

And there is “Versuchsweise” Kernel:openSUSE-15.0
Note, that the link is below “Distributionen openSUSE Tumbleweed”

I need to keep the kernel at least up the next update of Intel parallel studio.

Next question, which tag do I then need to add to /etc/zypp/zypp.conf to keep the kernel in my multiboot configuration?

Thanks a lot for the guidance on what to do best!!

P.S.: Although I’m German, I have no idea what is meant with “Versuchsweise”. The page is unfortunately in German and I see no option to switch it to English.

Ummm, don’t, unless you happy with an insecure system?

I see there is an update planned in the thread listed, but also access to the pre-release version, ask for that and move on…

Sorry, I don’t understand anything from your answer:

  • in which “thread listed” is an update planed? What does it mean
  • “but also access to the pre-release version”??
  • “ask for that” ask where?

In the beginning of the thread there was warned to use a Leap kernel in TW, but now I found the Leap kernel under “tumbleweed distribution”. Does this mean, that the Leap kernel is also available under TW? Is it save to use this one?

Do you refer to this Leap 15.0 kernel package?

BTW, I need the sources for the kernel, too, to build by vtunes driver.

Honestly I prefer unsecure over not being able to use vtunes.

Thanks for a clarification.

Sorry, now I understand! I was not aware of an response from Intel on the issue thread meanwhile.

Now your response makes perfectly sense - thanks for pointing this out!

P.S.: I cannot edit my previous answer any more.

See here: