How can I disable touchpad tap-to-click in 11.4 GNOME (Sony Vaio)

I have a brand new Sony Vaio S with a big sensitive touchpad that is making it very difficult to type more than a couple lines without accidentally clicking something. I’ve been scouring the internet for a way to turn off touchpad tap=click this evening and have decided I need to post this here. Some things I’ve learned already:

First of all, I have installed synaptic (which did not come pre-installed with 11.4 interestingly). When I try to run it (or when I click “TouchPad” in Control Center I get the following classic error:

GSynaptics couldn’t initialize.
You have to set ‘SHMConfig’ ‘true’ in xorg.conf or XF86Config to use GSynaptics

Regarding “/etc/X11/xorg.conf”: this file does not exist in 11.4. Instead there is “xorg.conf.install” and a directory called “xorg.conf.d” There is a file “50-synaptics.conf” in the directory. Adding:

Option “SHMConfig” “true”

here does not allow me to run synaptics. Being unable to run synaptics, I looked for other ways. A lot of people simply changed their “/etc/X11/xorg.conf” (which again does not exist) to include

Option “MaxTapTime” “0”

I’ve tried adding this to “/etc/X11/xorg.conf.install” and to “/etc/X11/xorg.conf.d/50-synaptic.conf” to no avail. Which leads to this forum post and me being out of ideas.

Thanks in advance.

Well it looks like this might force me to switch Distros. Pretty lame as I have used openSUSE a lot and really liked it. But I have tried so many different avenues to disable something as simple as touchpad clicking and have reached a deadend every time. Editing the config files doesn’t work. gsynaptic is deprecated and I can’'t get its replacement, gpointing-device-settings, to build in SUSE. I’m also getting shockingly little support here, at least compared to what I’ve experienced with other distros.

What I found I had to do, was first boot to Windows where it is set to disabled. Then reboot to linux.

When I installed 11.3, for various reasons I decided to switch to KDE. And in KDE, it turns out that tap-to-click is disabled by default (though you could enable it). And there’s another wonderful feature. You can set it so that if you plug in a usb mouse, then the touchpad is completely disabled. The same features are there in 11.4.

You disable it pretty much on the same place you disable it for any distro with GNOME:

System > Hardware > Mouse > Touchpad tab. (check the available options)

Since I have really no clue on what kind of configuration you are running (as menu’s and friends can different), you can also run ‘gnome-control-center’ from a console (or ALT+F2) and check the mouse there… it’s the same application…

If you want to launch the application directly from a terminal, try: gnome-mouse-properties.

The tab you are looking for is ‘Touchpad’.

Feel free to change distributions if that pleases you, regardless of the one you pick (since most ship upstream GNOME), the tip above will also work and the panel will look the same as the one bellow (maybe with a different GTK theme).

That tab is not there. Trust me, that was the first thing I looked for, way before I sought help. The problem here is that gsynaptics is deprecated and non-functional in 11.4. It depends on the xorg,conf file that no longer exists in 11.4. I couldn’t get its replacement, gpointing-device-settings, to build in 11.4, so I had to give up there.

I apparently can’t edit posts on this forum, but here’s a screenshot:

My belief is that this tab is missing because gsynaptics is not functioning properly. What I think might fix this is if I spoof a xorg.conf file just for gsynaptics to look for. The problem with gsynaptics is that it looks for the option “SHMConfig” “true” in /etc/X11/xorg.conf, which does not exist in openSUSE 11.4. This is probably part of why gsynaptics is deprecated.

I’d rather get gpointing-device-settings to build though, I might be posting another thread about that somewhere else.

That jab about changing distros was mostly me being frustrated that entire days were going by without getting a response on the distros official support forums. I’m well aware that GNOME is (mostly) the same on any distro. Just because I only have 4 posts here doesn’t mean I’ve never used Linux before.

Ok, if you are sure that gpointing-device-settings will solve your problem, it’s available for openSUSE 11.4 in the Contrib repo’s. A more orthodox way to install the repo would be (as root):

cd /etc/zypp/repos.d && wget -c

This will install the repository meta file on the right spot… then you only need to refresh the repo (and accept the key) and install the package:

Refresh the repositories (also as root):

zypper ref

Install the package (also as root):

zypper in gpointing-device-settings

From that point on, I’m not really sure what to do, but the package is available on the Contrib repo :slight_smile:

I’m not also sure if this will help, and even without the xorg.conf present you can try to check /etc/X11/xorg.conf.d/50-synaptics.conf which seems to be the best place to tweak for your system…