How can I debug a problem with a Java applet based Remote Desktop Connection

I’ve just installed a fresh OpenSUSE 12.1

I’ve switched to sun jre 1.6 by following the steps given here: https://sites.google.com/site/easylinuxtipsproject/java-for-opensuse

I connect to my work portal using Firefox and the Cisco runtime applet starts but complains it cannot connect to the IP address for the target machine.

  • I’ve checked the firewall is off
  • I’ve checked the IPV6 is disabled

I can connect successfully using the Firefox and the same applet and the same IP address using Windows7. (Dual booted from the same laptop, connecting via the same wireless network/router)

I had this working before with opensuse11.3

It appears to be a configuration problem with opensuse that is effecting network connections.

Does anyone have any tips of things to try or further debug? (Ie is there a log anywhere when an applet runs?)

Thanks

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Just guessing, but are you sure of the Java that Firefox is using after
your change over? Put ‘about:plugins’ in the URL/address bar to verify.
If you have IcedTea in there still perhaps the applet is not compatible
with that Java and it’s causing the issue.

Good luck.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.18 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJPaHvDAAoJEF+XTK08PnB5bEoQAKmm9SBLRTQvtmgzixBHncig
FvulRuJ3Ewp9/ayLCspr6pOiNAnk8rR5IbnREVcEt9hz3aBerEuygMDSWXG8S5Ic
oZpb3P3IHVbSeBEBQ4PeyN5NCzm52VcahcsH69FRK9tR84+5H/ffylUVjnddfvxr
EEVrkW0+/xb0Qq6ShxpnqcrcLv8+BQA15uVBXuL53xlSNfX/z4wqnL7q2tf+tncc
OcyaTqYzNVp1xdraeeq9jzJ3mmITUFisCdmAvowm7O3zcSxPmJwvD6u+ViRmLNmb
s7b0BeAX1aonkOOt06JdfJHZBUdejCKeuOZBjPwS1Gh3b4zUYEi3FKvYxVDi2lva
k5VcsM92G+EUnay1DOGHTa2Csb7S9xUCZT5SyNYkj5DlCo/FO2X/Bw73F0cY+/HA
UucJrp557U2BFUfr/WZcSxXOxFqtTwzGIXcDbfM4euoCHahjy5wb3jcWT0P+hNEA
px/flrXM+C7boq+gEDbAOZ6uj+gYIYDGQKJuqptIF5rPZrhCjTRfKgQtW65PZNAc
wXEt37eoS4q0zoaTyBfxjFXf/3BGM00z9EisqQpG82CUeCngP9wsBGuAg/WhyBuB
00CpzSR/ID9uq5R5FpekWmCIFqoyCIGnpCJdp0Y1F3Q39fIcvp6BFQEUsOj9lJQi
pW4GLlQ2az9OqcfKzhBX
=2xZg
-----END PGP SIGNATURE-----

Yes, I should have said, I’ve confirmed the plugin is the correct one using about:plugins as you describe

The rdk client does not even start with IcedTea, very noticeable difference.

Cheers

To me, the guide you referenced at Google is uncomfortably possibly incomplete… I suspect that in many situations those instructions will work, but because a system which might have had some kind of Java installed earlier could vary in so many ways, it’s limited in any kind of “upgrade.”

Recommend for starters…
Use the “update-alternatives” utility to verify what type of Java is currently enabled, use it to enable/disable to your needs.
I don’t know the requirements of your Java plugin, but consider that you may need to configure Java HOME (is not mentioned at all in the guide).
The guide for some reason describes removal of older Java packages which is totally unnecessary, IMO doing so only increases chances of error. openSUSE supports multiple JRE and JDE instances and through the use of update-alternatives you can switch from one installed instance to another.
The guide for some reason describes configuring the default Java from the CLI, IMO using the update-alternatives application interface instead of CLI is much safer.

One of the problems of using an inadequate reference like the Google reference is that your system is in an unknown state. If you aren’t able to solve your issues using “normal” means, you may need to remove Java as much as possible and then re-install.

HTH,
TS

Thanks for your reply.

I added the sun jre on a fresh install and selected it to be my default using update-alternatives interactively.

*# update-alternatives --install “/usr/bin/java” “java” “/opt/java/64/jre1.6.0_31/bin/java” 1

update-alternatives --config java*

Still getting the same problem.

I’ve tried to connect using three browsers :firefox, konqueror and chrome, ALL give the same error
I’ve tried 3 or 4 different releases of sun jre v 1.6, all behave the same

I still think this is an openSuse 12.1 problem. Everything else seems to be eliminated.

Good news is there is a VNC plugin which works well, so I can achieve my end goal of remote connection.

Any further ideas appreciated

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Have a link to a site we can try?

Good luck.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.18 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJPa6cYAAoJEF+XTK08PnB5uBMQAIFj/dMEtiZ/fZUNXTYncCZL
hcqxJv4tWxjYZDm6D9rl79fsLMzC1Yvs490Tn1QDQkLm17kSL6qn4/t8NDO/MEn8
gpifuq2ozbz3gk5Ga5x/XSNgMq+sbdpTCqPOMk5QVwt9KbGbxFfzshRFBi2/LIUA
Q2wTN90UQqthmbZFyZ41aY71LXqfIBAz2nnD155Wi52WTmgnW0aBHqZfF7tZZ/1h
zoNexeJF28+xYigifJvr1eQGQj/ghEHKEE/uEnOzT7+FgowXLdfeH9XZfAu+URJl
FYgUZxhsdW3kwwlECWgTEb2S3CC8HTWLiK3hn1T8FH27qP1LsWm4wAmZmV8DuExL
6cs1JUub6DcjhPWS7tPqaofUx/cEzSByLuAKUGXxX+voyGzV7vP8iUjPgOo6B2wS
R2LyIaYYNvg6wvkPbVitQ/h3LqSX/QN3Ajk3Hl8h74KfQgk9T7Bp8g8GqbkLkszB
GtX0Xa59/0h+yAwH77mOL85qzTzY/8wRxkzgkKByvLH7km+1BRzWjQReK6OyEkJQ
MVQv9yj9fZpTfKISGnvAYqsMoX/5ZcF6nl43k+DRobH9yiE3nB8e7Rh/c6NnbkOY
81yme/2optrGc6VmgG9ZYvwiPCLNY0/BPkE6YfNLm0s4XG2ZUjUKZd+52SvxbLja
HZ7aB4LuTApv7zFXQFOr
=mZwV
-----END PGP SIGNATURE-----

Unfortunately I can’t post a link because it’s on a corporate network via a portal with password access.

I’m okay with VNC but it’s not as fast.

Think I’ll try some live distros to see if any behave differently.

Cheers

Try to enable ipv6. Disabling it seems problematic in some cases.

Best regards,
Greg

No mention was made whether Java was configured properly (my Java HOME reference).

Ordinarily, although HOME can be configured in a few places, the recommended location is to create a profiles.local file containing the necessary paths and configurations.

TS

Hi,

I haven’t had chance to set up IPV6, did not look trivial so I shied away from it.

I did not explicitly set JAVAHOME but other java apps etc work (eg VNC plugin)

I’m setting up a JDK at the moment and fiddling with update-alternatives again, so will look into it.