how can i build a distro based on my local system?

hi all.

i have a question if you don’t mined:
i have got an account on suse studio,and i want to create a distro based on opensuse 11.4 using my local system,i mean to have the same updates and programs and improvements that is installed on my computer,how can i do this please?


Since you did not get a reply until now I will try to give you some thoughts
what I would do.

Suse Studio allows you to upload an autoyast file (I never tried that option
but you can do and see how it works for you).

The first step is of course that you need such an autoyast file. Most
probably you did not use the option to create one when your original
installation was finished. So you you have to do it now.

The command for this is

su -
yast2 clone_system

this will create by default a file autoinst.xml in /root which you should
copy to a place which is more useful.

Now login to suse studio and in the menu at the top choose Studio.
It presents you a page with predefined templates, one of them has the name
“Import”. Choose it and it gives you the possibility to upload your

Now follow the usual steps to create the appliance.

PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.2 | GeForce
9600 GT | 4GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
ION | 3GB Ram

ok, i have followed these steps,but until this moment the build process didn’t complete! i have left the computer on for 8 hours! :slight_smile:

while suse studio was building the distro, i have got the following error:

useradd: UID 102 is not unique.

Try changing the assigned UIDs, or allowing them to be assigned automatically.

why is that?

Check your Users ID: may be you have two users with UID 102. You can use this command:

cat /etc/passwd |grep 102

the third occurrence on each line is the UID (the field-separator is “:”)

excuse me for my Ignorance,but what is the ‘UID’???

Unique Identification Number ? :wink:

ok,the result of ‘cat /etc/passwd |grep 102’ is:

ntp:x:74:102:NTP daemon:/var/lib/ntp:/bin/false

what now??

up up up up up up!

yast2 clone_system
this also will include the softwares, those are independent from suse’s software repos?

hate to be a buttinsky…
but “yast2 clone_system” doesn’t work on my gnome system for some reason.
I plowed through the man and info pages but nothing. not even a mention of
it. I get

No such client module clone_system
The search path follows. It does not include the current directory.

Run 'yast2 -h' for help on usage

I have 82 yast2 packages installed but I give pause to blindly installing packages these days.

Description:    openSUSE 11.4 (i586)
Release:    11.4
Codename:    Celadon
gnome 2.32.1
Information for package yast2:

Repository: @System
Name: yast2
Version: 2.20.12-3.2
Arch: i586
Vendor: openSUSE
Installed: Yes
Status: up-to-date
Installed Size: 3.5 MiB
Summary: YaST2 - Main Package
This package contains scripts and data needed for SuSE Linux installation with YaST2

What am I missing for this clone_system to work?

autoyast2 is the correct answer.

Thank you for your time.

On 06/07/2011 05:06 AM, Habitual wrote:
> but “yast2 clone_system” doesn’t work on my gnome system for some
> reason.
> autoyast2 is the correct answer.

are you saying that autoyast2 is the answer to your needs and this
problem is solved, for you?

via NNTP openSUSE 11.4 [] + KDE 4.6.0 + Thunderbird 3.1.10
Acer Aspire One D255, 1.66 GHz Atom, 1 GB RAM, Intel Pineview graphics

  • When your gecko is broken you have a reptile dysfunction! *

</buttinsky> :slight_smile:

Neither one of them work on my kde system.