How can I adjust screen brightness in OpenSUSE-LXDE???

I use OpenSUSE-LXDE 11.3 for my laptop Dell Inspiron N4010. Everything is good but I can’t adjust brightness to save power for my laptop :(.
I can use function key on my keyboard, the ruler of brightness show and change but brightness don’t change :(. And I have tried using laptop-mode-tool but result don’t improve
How can I do it???

P/S I’m Vietnamese and my english is bad :frowning:

Had the same problem, gladly fixed it with these steps of 1,2,3,4,5,6

  1. Go to YaST
  2. Choose “System” at left panel
  3. Choose “Boot Loader” at right panel
  4. At “Boot Loader Settings”, choose the openSuSe partition/label then “edit”
  5. At “Optional Kernel Command Line Parameter”,

add

acpi_osi=Linux

to the end of the textbox.

mine, looks like this

resume=/dev/disk/by-id/ata-Hitachi_HTS545032B9A300_100218PBN3041THNNKHR-part6 splash=silent quiet showopts acpi_osi=Linux

  1. “OK” , then restart the computer
  2. Then, tell me if it works for you :slight_smile: or
  3. Ask me if any step above is not clear :slight_smile:

It works for me, hope will be for you too ( if y have not found a fix yet)

I used both Ubuntu 10.10 & OpenSuSe 11.3 KDE , the solution works for both for my same Acer laptop :slight_smile:

I thought it was good ! :slight_smile:

source - [ubuntu] Brightness problem in Ubuntu 9.10 on Acer Extensa 5235 - Ubuntu Forums](http://ubuntuforums.org/showthread.php?t=1387627)

@ANewSon Thanks for your helping, I’ll try it a.s.a.p but not now because my laptop have broken down. By the day, it’s haven’t been repaired.
When it’s repaired and i can use it, i’ll try your instruction and say result to everyone who get this problem :D.

Very bad, it don’t work for me :(.

There is a command xbacklight which works from a terminal as normal user. Worth investigating at least. From the man page:
Xbacklight is used to adjust the backlight brightness where supported. It finds all outputs on the X server supporting backlight brightness control and changes them all in the same way.
Use the command xbacklight --help for help with parameters:


usage: xbacklight [options]
  where options are:
  -display <display> or -d <display>
  -help
  -set <percentage> or = <percentage>
  -inc <percentage> or + <percentage>
  -dec <percentage> or - <percentage>
  -get
  -time <fade time in milliseconds>
  -steps <number of steps in fade>

Let us know if it workS for you, or post back with any further questions. :slight_smile:

Please try this old thread, it might help.
See the part of thread with “xgamma”

http://forums.opensuse.org/english/get-help-here/applications/447600-brightness-gnome.html

I try to use it and i get error: No outputs have backlight property. :frowning: What???
My “brightness” file in location: /sys/class/backlight/dell_backlight/. I changed value in it and but when i restart my laptop, value is reseted :(.
@conram I think xgamma only change colors-dept, not brightness >"<. Felling darker because your colors-dept changed, but brightness doesn’t change.

That command worked on my notebook (Lenovo), but the backlight setting also gets reset on restart.

On mine I have /sys/class/backlight/acpi_video/ directory with three further sub-directories, and several files including actual_brightness, brightness, and *max_brightness *. My notebook currently relies on standard ACPI kernel modules for its backlight controls which work through the ACPI video module.

To see if that module is loaded on your system, you can use the following command (as normal user):

lsmod | grep video

Look for “video” module in the listed output. The module names to the right show which other modules are using it.

Alternatively, your laptop may be using a custom ACPI package for your make/model.

Not just a problem on openSUSE, take a look at this post from Ubuntu’s forum.

This problem seem to be serious
Result got when i type lsmod | grep video in terminal


FirePhoenix@firephoenix:~> lsmod | grep video
uvcvideo               68119  0 
videodev               43828  1 uvcvideo
v4l1_compat            17249  2 uvcvideo,videodev
v4l2_compat_ioctl32    11349  1 videodev
video                  25256  1 i915
thermal_sys            18230  4 video,fan,processor,thermal

No idea in topics which you post can help me solve my problem :frowning:
My kernel’s version

FirePhoenix@firephoenix:~> uname -a
Linux firephoenix.site 2.6.34.7-0.5-desktop #1 SMP PREEMPT 2010-10-25 08:40:12 +0200 x86_64 x86_64 x86_64 GNU/Linux

My location /sys/class/backlight/dell_backlight/ included folders and files as same as you
I hope this problem will be solved in OpenSUSE 11.4 :frowning:

Serious, because it affects various models of laptop running linux including yours, and mine to a lesser extent. I found this generic bug report on acpi bugzilla. Over two months old, it represents a “gathering of all the bugs that ACPI backlight control is broken”. That bug report is not very technical and in good english, so do try to read it.


FirePhoenix@firephoenix:~> lsmod | grep video
uvcvideo               68119  0 
videodev               43828  1 uvcvideo
v4l1_compat            17249  2 uvcvideo,videodev
v4l2_compat_ioctl32    11349  1 videodev
video                  25256  1 i915
thermal_sys            18230  4 video,fan,processor,thermal

At least that is identical to mine, and shows the appropriate kernel module is loaded.

No idea in topics which you post can help me solve my problem :frowning:

Sadly, I probably won’t be able to solve your problem. Sometimes the best we can do is assist you to investigate further and gather information. At least you now know it’s probably a linux/acpi problem, and not specific to a single distro.

Your kernel’s version is the same as mine and completely updated for 11.3 distribution. It’s always possible that a newer kernel may solve the problem, but without much confidence given the closing comments in that acpi bug report:

In a word, this bug report is a gathering of all the bugs that ACPI backlight
control is broken and we don’t/can’t fix in Linux/kernel.

At least that bug report indicates that an acpi developer is “planning to re-write the backlight sysfs class device to a backlight manager.” :slight_smile:

What happens if you add this to the options line when booting the normal kernel?

acpi_backlight=video

Then try xbacklight from a terminal (normal user). Post back with the result (if any).

I cannot check that on mine, since that is its normal acpi mode of working. However, if I boot with option acpi_backlight=vendor, when I later run xbacklight from a terminal it behaves like yours and reports “No outputs have backlight property”.

I’m sorry, I see. I just want to find out solution for my problem. I have tried to find solution since Semtemper but I’m not lucky so I post this topic when everyone can discuss about it and if I were lucky, I and someone who get this problem could completely solve our problem :(.

At least that bug report indicates that an acpi developer is “planning to re-write the backlight sysfs class device to a backlight manager.”

I hope it will be relased soon.
Nothing changes when I add acpi_backlight=video to boot option and badly, I get other problem which I can’t use Fn+F4, Fn+F5, used to change brightness in my laptop.

Today I’ve carefully read bug report. Someone tell this problem can be solved by using native driver. I’ve found information about it in internet and get something but I really don’t understand how to install i915 native driver and what way it do.
One page is quoted in bug report:

http://marc.info/?l=linux-kernel&m=129018215513192&w=2
Not all systems expose a firmware or platform mechanism for changing the
backlight intensity on i915, so add native driver support.

But I don’t understand everything below this sentence :frowning:
How do it? Can everyone help me?