How can disable my microphone?

A little bit of hardware information:
I’m using an A8JS laptop equipped with an Intel HD audio.

Anyway, I have a bit of a problem where the mic squeals and drives me nuts in class if I touch it. However, this only seems to happen when the laptop is running off battery power and I don’t have headphones plugged in. Otherwise I can poke all I please with it making any noise (as in it’s plugged into the wall and no headphones are plugged in). I’ve checked kmix and the speakers and mic are muted and reduced to a minimum volume, but doesn’t really help.
I think it would be nice to completely disable the mic at a lower level, but I don’t how that’s done. Any suggestions?

This is probably system notifications:](](

The Powerdevil settings takes ages to work thru

OK, now that I’m home, I have to admit I have no idea what causes it. It’s a not a system notification issue, as I have all of those disabled (they’ve always driven me nuts :p), but it’s that laptop squeal you get from having the mic too close to speakers, and then you get an annoying high pitched loop. (You can try it with 2 cell phones… kinda fun :D)

Usually this isn’t a problem, but sometimes the audio settings I choose don’t really “stick” so to speak. I was hoping that I could do something special that would disable or make my computer ignore the mic altogether. I never use my mic anyway, soooo… I’m not really losing anything.
What I have thought of, but this is a very ugly hack, is that I can just put a plug into the headphone jack and maybe another into the mic so that it won’t bug me. Ya, not pretty. :\