How are your boot times with 11.4?

After I checked bootchart to see what was taking up time during my boot sequence, I added the following parameters to the boot screen to see how it would speed up my boot time:

apparmor=0 akonadi=0

My machine booted in 25 seconds. My hardware is AMD Phenom II Quad 3Ghz, 8GB ram, nVidia 250 GTS. Anyone else want to try these mods and see what they get?

So this sounds very interesting indeed. On my openSUSE 11.4 machine, I just gave this a try. It already boots very fast because it uses an SSD right now. But, I did not notice any additional speed. From when to when are you clocking 25 seconds? From the time I see my video card sign on till I can press enter to select my normal openSUSE 11.4 is perhaps 3 seconds. From then, till I can log in is perhaps another 15 seconds. It takes time to login but I am at the KDE desktop in 25 seconds from pressing enter in the grub menu, but my music does not play for another 10 seconds and perhaps all done at 35 seconds plus 3 from the boot to grub. I consider this fast enough, but not sure if these two parameters helped. They did not seem to hurt, just yet, but I had already disabled apparmor as it keeps Samba from working properly right now. I am not so sure about the akonadi command. Why not tell us more about how you are testing this speed.

Thank You,

I’m timing from the time I press enter after I add the options I mentioned above. I have noticed that sometimes kmix and the other applets in the panel at the lower right take an extra twenty seconds to appear and I hear the start up sound. Other times they appear as soon as I see the desktop wallpaper.

Before adding the options, my boot time was 50 seconds according to bootchart, with apparmor and akonadi taking up the most time after plasma. My BIOS screen lasts for about 3-4 seconds before that. I rarely see the nvidia splash screen.

My times are on par with jdmcdaniel3. The options didn’t change the boot time too much, a second maybe. 7200 spindle speed.

wouldn’t disabeling Apparmor and akonadi from their respective setup screens will do the same thing?

Where do I disable akonadi? I couldn’t find that screen. Note that I use KDE.

I use KDE too. I don’t remember the exact steps, but if you go to System Settings, under Desktop Search (i think) you will find the controls for Akonadi.

There are controls there for nepomuk.

I did turn off nepomuk, both there and in the services section of “Startup and Shutdown”. However, when I look at running processes, akonadi and nepomuk both seem to be still running. They may be idle, but the processes are there.

If I go into $HOME/.config/akonadi/akonadiserverrc and edit the “StartServer” line (change from true to false), I think that prevents it from starting up, or at least cause akonadi to quickly shutdown. But I haven’t found any other controls. In 11.3, there were explicit settings for akonadi, but they don’t seem to be there in 11.4

I’ve seen this happen too on a laptop that I installed 11.4. It’s a little annoying as the whole desktop seems sluggish and non responsive until the rest of the icons appear and startup chime plays.

I think the boot times are slower than with 11.3. I haven’t timed them but it definitely takes longer to get to a full working desktop now.