Hotspot creation not working? (KDE)

I tried to set up hotspot, from network manager, create shared wifi, assign ssid and password.

but I cant connect to that hotspot. There are no option to do that.

I have done this before, I dont remember it was this hard to get it working.

any idea of what I might have missed?

https://i.imgur.com/aNqzpSL.png

Hi,

I already had a hotspot config, which works OK. Created a new one, result is OK.
How do you create the hotspot?

Nothing unusual in particular.
Right-click on network icon -> configure network connections.
Add. -> Wifi (Shared).
https://i.imgur.com/Tb9YzZa.png https://i.imgur.com/msd06Eo.png
https://i.imgur.com/vGFlngQ.png https://i.imgur.com/rjtkgSg.png

Ok.

I dont know if it is related or not, but I have turned off Susefirewall. (prefer to manually manage iptables).

1 Like

Hello,

i’m having the exact same problem. My wireless card supports AP, i checked this with

iw list

I have

hostapd
dnsmasq

packages installed and done the same steps as razirazo mentioned, with the same disappointing result.
Any help would be appreciated.

Mmm, weird. Just updated, tried again and got a working hotspot. I’ve been wondering whether it could be the “-” in the SSID, but AFAIK that shouldn’t be an issue.

Tried to set up the hotspot on the same laptop with ubuntu 16.10 (live distro on usb stick).
Followed this instructions: http://ubuntuhandbook.org/index.php/2016/04/create-wifi-hotspot-ubuntu-16-04-android-supported/
and succeeded!
Well, establishing a hotspot on this laptop is possible.
Since the ubuntu networkmanager is so similar to the kde one i tried it again with kde.
I didn’t find how to connect to a hidden network in kde as in ubuntu so i followed this instruction: https://yuenhoe.com/blog/2011/02/connecting-to-hidden-wireless-networks-using-kdes-networkmanager/
but no hidden network did appear.
I’ve run out of ideas.

Okay I got it working.

Not really sure what the exact problem is,
Apparently when creating the hotspot, I have to select “Wireless” instead of “Wireless (Shared)”.

Strange. But well, whatever. At least it worked.
https://i.imgur.com/wES6dRg.png

Thank you. Got it working too that way!
I also don’t understand what the difference is between ‘wi-fi’ and ‘wi-fi (shared)’.

One last problem: Creating an AP that way gives me a new ip address range, e.g. 10.1.42.x whereas my home network actually has ips 192.168.0.x.
Is there a way to configure the hotspot that it doesn’t create its own address range?